<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html dir="ltr" lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://seatacblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://seatacblog.com';var et_post_id='141291';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10 | The SeaTac Blog</title>

<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The SeaTac Blog | SeaTac News, Crime, COVID-19, Events, Politics &amp; more" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10 | The SeaTac Blog" />
<meta property="og:url" content="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/" />
<meta property="article:published_time" content="2022-05-08T16:58:32+00:00" />
<meta property="article:modified_time" content="2022-05-08T16:58:32+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/seatacblog" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@theseatacblog" />
<meta name="twitter:title" content="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10 | The SeaTac Blog" />
<meta name="twitter:creator" content="@theseatacblog" />

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Feed" href="https://seatacblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Comments Feed" href="https://seatacblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The SeaTac Blog &raquo; iCal Feed" href="https://seatacblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10 Comments Feed" href="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/seatacblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='gtranslate-style-css' href='https://seatacblog.com/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.9.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://c0.wp.com/c/5.9.3/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://seatacblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://seatacblog.com/wp-content/themes/Extra-2/style.dev.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css' href='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/styles/magnific_popup.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/5.9.3/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/10.9/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.9/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.3' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts","ID":141291,"token":"a1f235ca3c","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://seatacblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seatacblog.com/wp-json/wp/v2/posts/141291" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seatacblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seatacblog.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://seatacblog.com/?p=141291' />
<link rel="alternate" type="application/json+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F05%2F08%2Fdeadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F05%2F08%2Fdeadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10%2F&#038;format=xml" />
<meta property="fb:pages" content="293605064226" />
<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://seatacblog.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://seatacblog.com"><link rel="alternate" href="https://seatacblog.com/wp-json/tribe/events/v1/" /> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://seatacblog.com/wp-content/uploads/2020/09/STBFavicon.jpg" /><link rel="amphtml" href="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/?amp">
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHDHPPP');</script>

<script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE SEATAC BLOG...').css('opacity','1'); 
});
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20430280-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20430280-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=VM5WbNEfwY9oXPbxN3ihiy5E";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://seatacblog.com/wp-content/cache/et/global/et-extra-customizer-global-165030403648.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-141291 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fixed_nav et_smooth_scroll et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-138191" class="et-trending-post et-trending-latest">
<a href="https://seatacblog.com/2019/10/31/letter-a-statement-from-seatac-city-council-candidate-takele-gobena/">LETTER: A statement from SeaTac City Council candidate ...</a>
</div>
<div id="et-trending-post-138718" class="et-trending-post">
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/">King County will turn Quality Inn hotel in SeaTac into ...</a>
</div>
<div id="et-trending-post-139049" class="et-trending-post">
<a href="https://seatacblog.com/2020/07/06/king-county-sheriff-issues-statement-regarding-offensive-facebook-posts/">King County Sheriff issues statement regarding offensiv...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://seatacblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://seatacblog.com/" data-fixed-height="51">
<img src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" alt="The SeaTac Blog" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-136055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-136055"><a href="https://seatacblog.com">Home</a></li>
<li id="menu-item-136190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136190"><a href="https://seatacblog.com/category/crime/">Crime</a></li>
<li id="menu-item-140620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140620"><a href="https://seatacblog.com/category/politics/">Politics</a></li>
<li id="menu-item-136174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136174"><a href="https://seatacblog.com/events/">Events</a></li>
<li id="menu-item-136059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136059"><a href="https://seatacblog.com/jobs/">Jobs</a></li>
<li id="menu-item-137992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137992"><a href="https://seatacblog.com/category/business/">Business</a></li>
<li id="menu-item-137987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137987"><a href="https://seatacblog.com/weather/">Weather</a></li>
<li id="menu-item-140120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140120"><a href="https://seatacblog.com/webcams/">Webcams</a></li>
<li id="menu-item-137986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137986"><a href="https://seatacblog.com/advertise/">Advertise</a></li>
<li id="menu-item-136062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136062"><a href="https://seatacblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136264"><a href="https://seatacblog.com/about/">About</a></li>
<li id="menu-item-139251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139251"><a href="https://seatacblog.com/support-local-journalism/">Support Local Journalism</a></li>
<li id="menu-item-139056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139056"><a href="https://seatacblog.com/subscribe-to-our-daily-digest-email-newsletter/">Subscribe to our Daily Digest Email Newsletter</a></li>
<li id="menu-item-136061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136061"><a href="https://seatacblog.com/contact/">Contact</a></li>
<li id="menu-item-136060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136060"><a href="https://seatacblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-138478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-138478"><a href="https://seatacblog.com/privacy-policy-terms/">Privacy Policy/Terms</a></li>
</ul>
</li>
<li id="menu-item-140208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-140208"><a href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2022/02/BHHSMenuButton200-22d.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="170" height="81"></a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-141291" class="module single-post-module post-141291 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-featured-post category-news category-non-profit category-seatac category-seatacnews tag-education tag-news-scholarship tag-rotary-club-of-seatac-tukwila tag-schools tag-seatac tag-seattle-southside-chamber-of-commerce tag-students et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10</h1>
<div class="post-meta vcard">
<p><span class="updated">May 8, 2022</span> | <a href="https://seatacblog.com/category/education/" rel="tag">Education</a>, <a href="https://seatacblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://seatacblog.com/category/news/" rel="tag">News</a>, <a href="https://seatacblog.com/category/non-profit/" rel="tag">Non-profit</a>, <a href="https://seatacblog.com/category/seatac/" rel="tag">SeaTac</a>, <a href="https://seatacblog.com/category/seatacnews/" rel="tag">SeaTac News</a> | <a class="comments-link" href="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://seatacblog.com/wp-content/uploads/2022/05/STB-RotaryChamberScholarship22-1280x640.jpg" alt="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<blockquote><p><strong>EDITOR&#8217;S NOTE</strong>: <em>South King Media Founder/Publisher Scott Schaefer serves on the Board of Directors for the Seattle Southside Chamber of Commerce.</em></p></blockquote>
<p><strong>Applications for a scholarship from the Rotary Club of SeaTac-Tukwila are now open, but the deadline is Tuesday, May 10, 2022 at 5 p.m.</strong></p>
<p>For more than 25 years the Rotary Clubs of SeaTac, Tukwila, and Southcenter have been awarding scholarships to deserving students at the five high schools in our communities, including Tyee, Foster, Seattle Christian, Raisbeck Aviation, and Puget Sound Skills Center.</p>
<p>About four years ago the three clubs united to form one to better serve the Tukwila and SeaTac communities.</p>
<p><a href="https://seatacblog.com/wp-content/uploads/2022/05/RotaryScholarshipFlyer.jpg"><img class="aligncenter size-full wp-image-141292" src="https://seatacblog.com/wp-content/uploads/2022/05/RotaryScholarshipFlyer.jpg" alt="" width="667" height="887" srcset="https://seatacblog.com/wp-content/uploads/2022/05/RotaryScholarshipFlyer.jpg 667w, https://seatacblog.com/wp-content/uploads/2022/05/RotaryScholarshipFlyer-226x300.jpg 226w" sizes="(max-width: 667px) 100vw, 667px" /></a></p>
<p>&#8220;We have continued our scholarship program, awarding an overall total of $15,000 including at least two students from each school,&#8221; organizers said. &#8220;The process of soliciting applications and selecting recipients has been conducted by our club members, who include several retired educators from the school districts we serve, in coordination with school counselors and administrators at each of the five schools.</p>
<p><strong>HOW TO APPLY</strong><br />
Follow the link below to apply for the scholarship!</p>
<h3 style="text-align: center;"><strong><a href="https://forms.gle/4EBpK2MJY8BGyUaQA" target="_blank" rel="noopener">https://forms.gle/4EBpK2MJY8BGyUaQA</a></strong></h3>
<p>The timeline for the scholarship applications will be:</p>
<ul>
<li style="list-style-type: none;">
<ul>
<li>May 10 &#8211; due date for applications to be completed;</li>
<li>May 11 &#8211; 19 &#8211; Applications will be reviewed</li>
<li>May 20 &#8211; Applicants will be informed of their application&#8217;s status</li>
<li>Week of May 23, exact date to be determined &#8211; The Rotary will hold an in-person event to award and recognize scholarship recipients and their families.</li>
</ul>
</li>
</ul>
<p><strong>SEEKING BUSINESSES PARTNERS</strong><br />
The process has been truly rewarding and inspiring, getting to know the applicants and hearing their accomplishments and their plans for their future, as well as their genuine appreciation for our support. We would like to expand and increase the support we offer to students in SeaTac and Tukwila, with help from the businesses in our communities. Your contributions will empower our club to double the impact we have on deserving and needy students. All your business has to do is contribute. We will continue to conduct the application and selection process. We will include representatives from your business in the awards ceremonies and will name scholarships after businesses that contribute at least $1100. You will be so impressed when you meet and get to know our scholarship recipients! We hope that your business will join us in this most important effort to support some deserving graduating seniors as they prepare to go to college and become successful adults.</p>
<p>For more information, contact <u><strong><a href="/cdn-cgi/l/email-protection#2968474d5b4c48697a4c485d5d454c7a465c5d415a404d4c6a4148444b4c5b074a4644">Andrea Reay</a></strong></u><strong> </strong>at the Chamber or <u><strong><a href="/cdn-cgi/l/email-protection#b3e0d6d2e7c6d8e3c1d6c0f3f4ded2dadf9dd0dcde">Paul Coblentz</a></strong></u> at the SeaTac Rotary Club.</p>
<p>&#8220;Thank you!&#8221;</p>

<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get more local SeaTac News FREE by email every day at 6pm!</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1770388516'><broadstreet-zone callback="zone_load_1770388516" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>window.zone_load_1770388516 = function(z, d) { if (!d.count) document.getElementById('zone_load_1770388516').style.display = 'none'; };</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/&#038;t=Deadline%20to%20apply%20for%202022%20scholarship%20from%20Rotary%20Club%20of%20SeaTac-Tukwila%20is%20May%2010" class="social-share-link" title="Share &quot;Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10&quot; via Facebook" data-network-name="facebook" data-share-title="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" data-share-url="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Deadline%20to%20apply%20for%202022%20scholarship%20from%20Rotary%20Club%20of%20SeaTac-Tukwila%20is%20May%2010%20https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/" class="social-share-link" title="Share &quot;Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10&quot; via Twitter" data-network-name="twitter" data-share-title="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" data-share-url="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/&#038;title=Deadline%20to%20apply%20for%202022%20scholarship%20from%20Rotary%20Club%20of%20SeaTac-Tukwila%20is%20May%2010" class="social-share-link" title="Share &quot;Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" data-share-url="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10&quot; via Email" data-network-name="basic_email" data-share-title="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" data-share-url="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10&quot; via Print" data-network-name="basic_print" data-share-title="Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10" data-share-url="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #f29e1a;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://seatacblog.com/2022/05/07/dubsea-fish-sticks-single-game-tickets-on-sale-now/" rel="prev"><span class="button">Previous</span><span class="title">DubSea Fish Sticks single game tickets on sale now</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://seatacblog.com/wp-comments-post.php?wpe-comment-post=seatacblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='141291' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="614fa4346c" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="82" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://seatacblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76520" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div class="tribe-compatibility-container">
<div class="tribe-common tribe-events tribe-events-view tribe-events-view--widget-events-list tribe-events-widget" data-js="tribe-events-view" data-view-rest-nonce="a1f235ca3c" data-view-rest-url="https://seatacblog.com/wp-json/tribe/views/v2/html" data-view-manage-url="1" data-view-breakpoint-pointer="8f9da72d-d698-4430-bdfb-de775c9cdda0">
<div class="tribe-events-widget-events-list">
<script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"Volunteers needed for North SeaTac Park Forest Rescue on Sunday, May 15","description":"&lt;p&gt;Volunteers are needed for a North SeaTac Park Forest Rescue on Sunday, May 15, 2022, from 10 a.m. \u2013 2 p.m. \u201cHelp restore beautiful North SeaTac Park\u2019s forest!\u201d Meet near [&hellip;]&lt;/p&gt;\\n","url":"https://seatacblog.com/event/volunteers-needed-for-north-seatac-park-forest-rescue-on-sunday-may-15/","eventAttendanceMode":"https://schema.org/OfflineEventAttendanceMode","startDate":"2022-05-15T10:00:00-07:00","endDate":"2022-05-15T14:00:00-07:00","location":{"@type":"Place","name":"North SeaTac Park","description":"","url":"","address":{"@type":"PostalAddress","streetAddress":"S. 136th Street &amp; Des Moines Memorial Drive","addressLocality":"SeaTac","addressRegion":"WA","postalCode":"98168","addressCountry":"United States"},"telephone":"","sameAs":""},"performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"SeaTac Business Forum Public Safety Series will be Thursday, May 19","description":"&lt;p&gt;EDITOR\\'S NOTE: South King Media Founder/Publisher Scott Schaefer serves on the Board of Directors for the Seattle Southside Chamber of Commerce. The Seattle Southside Chamber of Commerce will be holding [&hellip;]&lt;/p&gt;\\n","url":"https://seatacblog.com/event/seatac-business-forum-public-safety-series-will-be-thursday-may-19/","eventAttendanceMode":"https://schema.org/OfflineEventAttendanceMode","startDate":"2022-05-19T09:00:00-07:00","endDate":"2022-05-19T10:30:00-07:00","location":{"@type":"Place","name":"Online","description":"","url":"","address":{"@type":"PostalAddress"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"Seattle Southside Chamber of Commerce","description":"","url":"https://www.seattlesouthsidechamber.com","telephone":"(206) 575-1633","email":"&#104;&#116;t&#112;s&#58;&#47;&#47;www&#46;sea&#116;tl&#101;&#115;&#111;u&#116;&#104;s&#105;de&#99;h&#97;m&#98;&#101;r&#46;&#99;o&#109;/&#101;&#118;&#101;n&#116;&#115;&#47;d&#101;tails&#47;s&#109;art&#45;&#119;ebin&#97;&#114;-&#114;e&#111;pe&#110;&#105;&#110;&#103;&#45;&#115;tra&#116;&#101;&#103;&#105;e&#115;&#45;&#52;&#48;&#55;&#57;","sameAs":"https://www.seattlesouthsidechamber.com"},"performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4","description":"&lt;p&gt;Multi-Service Center\\'s Crab Feed and Auction will be held on Saturday night, June 4, 2022 at the Hyatt Regency Southport in Renton. &quot;Dust off your flip flops and join us [&hellip;]&lt;/p&gt;\\n","url":"https://seatacblog.com/event/multi-service-centers-crab-feed-and-auction-will-be-saturday-june-4/","eventAttendanceMode":"https://schema.org/OfflineEventAttendanceMode","startDate":"2022-06-04T17:30:00-07:00","endDate":"2022-06-04T21:00:00-07:00","location":{"@type":"Place","name":"Hyatt Regency Lake Washington","description":"","url":"","address":{"@type":"PostalAddress","streetAddress":"1053 Lake Washington Blvd N.","addressLocality":"Renton","addressRegion":"WA","postalCode":"98056","addressCountry":"United States"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"Multi-Service Center","description":"","url":"https://mschelps.org","telephone":"(253) 838-6810","email":"&#105;&#110;f&#111;&#64;m&#115;&#99;&#104;elp&#115;.&#111;&#114;&#103;","sameAs":"https://mschelps.org"},"performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"See BAT Theatre&#8217;s &#8216;The Play&#8217;s the Thing&#8217; FREE at Angle Lake Park July 29","description":"&lt;p&gt;BAT Theatre will be bringing the comedy The Play\\'s the Thing to various South King County parks this summer, including SeaTac. More cities are joining in, but mark your calendar [&hellip;]&lt;/p&gt;\\n","url":"https://seatacblog.com/event/see-bat-theatres-the-plays-the-thing-free-at-angle-lake-park-july-29/","eventAttendanceMode":"https://schema.org/OfflineEventAttendanceMode","startDate":"2022-07-29T19:00:00-07:00","endDate":"2022-07-29T20:30:00-07:00","location":{"@type":"Place","name":"Angle Lake Park","description":"","url":"","address":{"@type":"PostalAddress","streetAddress":"19408 International Blvd.","addressLocality":"SeaTac","addressRegion":"WA","postalCode":"98188","addressCountry":"United States"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"BAT Theatre","description":"","url":"https://www.battheatre.org","telephone":"(206) 242-5180","email":"&#105;nfo&#64;&#98;ur&#105;e&#110;&#97;ct&#111;r&#115;thea&#116;r&#101;&#46;&#111;&#114;&#103;","sameAs":"https://www.battheatre.org"},"performer":"Organization"}]
</script>
<script data-js="tribe-events-view-data" type="application/json">
	{"slug":"widget-events-list","prev_url":"","next_url":"","view_class":"Tribe\\Events\\Views\\V2\\Views\\Widgets\\Widget_List_View","view_slug":"widget-events-list","view_label":"Widget-events-list","view":null,"should_manage_url":true,"id":null,"alias-slugs":null,"title":"Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10 | The SeaTac Blog","limit":"7","no_upcoming_events":true,"featured_events_only":false,"jsonld_enable":true,"tribe_is_list_widget":false,"admin_fields":{"title":{"label":"Title:","type":"text","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-title","name":"widget-tribe-widget-events-list[2][title]","options":[],"placeholder":"","value":null},"limit":{"label":"Show:","type":"number","default":5,"min":1,"max":10,"step":1,"classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-limit","name":"widget-tribe-widget-events-list[2][limit]","options":[],"placeholder":"","value":null},"no_upcoming_events":{"label":"Hide this widget if there are no upcoming events.","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-no_upcoming_events","name":"widget-tribe-widget-events-list[2][no_upcoming_events]","options":[],"placeholder":"","value":null},"featured_events_only":{"label":"Limit to featured events only","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-featured_events_only","name":"widget-tribe-widget-events-list[2][featured_events_only]","options":[],"placeholder":"","value":null},"jsonld_enable":{"label":"Generate JSON-LD data","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-jsonld_enable","name":"widget-tribe-widget-events-list[2][jsonld_enable]","options":[],"placeholder":"","value":null}},"events":[141260,141286,141225,141244],"url":"https:\/\/seatacblog.com\/?post_type=tribe_events&eventDisplay=widget-events-list","url_event_date":false,"bar":{"keyword":"","date":""},"today":"2022-05-08 00:00:00","now":"2022-05-08 09:58:39","rest_url":"https:\/\/seatacblog.com\/wp-json\/tribe\/views\/v2\/html","rest_method":"POST","rest_nonce":"a1f235ca3c","today_url":"https:\/\/seatacblog.com\/?post_type=tribe_events&eventDisplay=widget-events-list&year=2022&monthnum=05&day=08&name=deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10","prev_label":"","next_label":"","date_formats":{"compact":"n\/j\/Y","month_and_year_compact":"n\/Y","month_and_year":"F Y","time_range_separator":" - ","date_time_separator":" @ "},"messages":[],"start_of_week":"0","breadcrumbs":[],"before_events":"","after_events":"\n<!--\nThis calendar is powered by The Events Calendar.\nhttp:\/\/evnt.is\/18wn\n-->\n","display_events_bar":false,"disable_event_search":false,"live_refresh":true,"ical":{"display_link":true,"link":{"url":"https:\/\/seatacblog.com\/?post_type=tribe_events&#038;eventDisplay=widget-events-list&#038;ical=1","text":"Export Events","title":"Use this to share calendar data with Google Calendar, Apple iCal and other compatible apps"}},"container_classes":["tribe-common","tribe-events","tribe-events-view","tribe-events-view--widget-events-list","tribe-events-widget"],"container_data":[],"is_past":false,"breakpoints":{"xsmall":500,"medium":768,"full":960},"breakpoint_pointer":"8f9da72d-d698-4430-bdfb-de775c9cdda0","is_initial_load":true,"public_views":{"month":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Month_View","view_url":"https:\/\/seatacblog.com\/events\/month\/","view_label":"Month"},"day":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Day_View","view_url":"https:\/\/seatacblog.com\/events\/today\/","view_label":"Day"}},"show_latest_past":false,"compatibility_classes":["tribe-compatibility-container"],"view_more_text":"View Calendar","view_more_title":"View more events.","view_more_link":"https:\/\/seatacblog.com\/events\/","widget_title":"Upcoming Events","hide_if_no_upcoming_events":true,"display":[],"subscribe_links":{"gcal":{"label":"Google Calendar","single_label":"Add to Google Calendar","visible":true},"ical":{"label":"iCalendar","single_label":"Add to iCalendar","visible":true}},"_context":{"slug":"widget-events-list"}}</script>
<header class="tribe-events-widget-events-list__header">
<h2 class="tribe-events-widget-events-list__header-title tribe-common-h6 tribe-common-h--alt">
Upcoming Events </h2>
</header>
<div class="tribe-events-widget-events-list__events">
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-15">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
15 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141260 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-15">
<span class="tribe-event-date-start">10:00 am</span> - <span class="tribe-event-time">2:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/volunteers-needed-for-north-seatac-park-forest-rescue-on-sunday-may-15/" title="Volunteers needed for North SeaTac Park Forest Rescue on Sunday, May 15" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Volunteers needed for North SeaTac Park Forest Rescue on Sunday, May 15	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-05-19">
<span class="tribe-events-widget-events-list__event-date-tag-month">
May </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
19 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141286 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-05-19">
<span class="tribe-event-date-start">9:00 am</span> - <span class="tribe-event-time">10:30 am</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/seatac-business-forum-public-safety-series-will-be-thursday-may-19/" title="SeaTac Business Forum Public Safety Series will be Thursday, May 19" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
SeaTac Business Forum Public Safety Series will be Thursday, May 19	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-06-04">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jun </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
4 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141225 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-06-04">
<span class="tribe-event-date-start">5:30 pm</span> - <span class="tribe-event-time">9:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/multi-service-centers-crab-feed-and-auction-will-be-saturday-june-4/" title="Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Multi-Service Center&#8217;s Crab Feed and Auction will be Saturday, June 4	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-07-29">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Jul </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
29 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141244 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-07-29">
<span class="tribe-event-date-start">7:00 pm</span> - <span class="tribe-event-time">8:30 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/see-bat-theatres-the-plays-the-thing-free-at-angle-lake-park-july-29/" title="See BAT Theatre&#8217;s &#8216;The Play&#8217;s the Thing&#8217; FREE at Angle Lake Park July 29" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
See BAT Theatre&#8217;s &#8216;The Play&#8217;s the Thing&#8217; FREE at Angle Lake Park July 29	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
</div>
<div class="tribe-events-widget-events-list__view-more tribe-common-b1 tribe-common-b2--min-medium">
<a href="https://seatacblog.com/events/" class="tribe-events-widget-events-list__view-more-link tribe-common-anchor-thin" title="View more events.">
View Calendar	</a>
</div>
</div>
</div>
</div>
<script class="tribe-events-breakpoints">
	( function () {
		var completed = false;

		function initBreakpoints() {
			if ( completed ) {
				// This was fired already and completed no need to attach to the event listener.
				document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
				return;
			}

			if ( 'undefined' === typeof window.tribe ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views.breakpoints ) {
				return;
			}

			if ( 'function' !== typeof (window.tribe.events.views.breakpoints.setup) ) {
				return;
			}

			var container = document.querySelectorAll( '[data-view-breakpoint-pointer="8f9da72d-d698-4430-bdfb-de775c9cdda0"]' );
			if ( ! container ) {
				return;
			}

			window.tribe.events.views.breakpoints.setup( container );
			completed = true;
			// This was fired already and completed no need to attach to the event listener.
			document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
		}

		// Try to init the breakpoints right away.
		initBreakpoints();
		document.addEventListener( 'DOMContentLoaded', initBreakpoints );
	})();
</script>
<div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://seatacblog.com/support-local-journalism/"><img width="300" height="250" src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="image wp-image-139276  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div> <div id="bs_zones-19" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78564" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://seatacblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe to our Daily Email Newsletter</h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our Daily Digest Email Newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> <div id="bs_zones-18" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#336666;border:1px solid #225555;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #225555'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Seattle-Tacoma International Airport</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-26'></i><span class='temp'>45°</span><div class='current_text'>Cloudy</div><div class='sunrise_sunset'>5:41am<i class='wi wi-fw wi-weather-32'></i>8:30pm PDT</div></div><span class='current_text_2'>Feels like: 41<small>°F</small><br />Wind: 6<small>mph</small> SSW<br />Humidity: 70<small>%</small><br />Pressure: 29.77<small>"Hg</small><br />UV index: 1</span><div class='daily days' style='border-bottom:1px solid #225555'><span class='extended_day extended_day_1'>Mon</span><span class='extended_day extended_day_2'>Tue</span><span class='extended_day extended_day_3'>Wed</span><span class='extended_day extended_day_4'>Thu</span><span class='extended_day extended_day_5'>Fri</span></div><div class='daily'><span class='extended_day extended_day_1' title='PM Showers'>55/43<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_2' title='AM Clouds / PM Sun'>57/43<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_3' title='PM Showers'>55/45<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_4' title='Rain'>52/39<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_5' title='Mostly Cloudy'>57/45<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #225555'><a href='https://www.weather-atlas.com/en/washington-usa/seattle-tacoma-international-airport' title='Weather Atlas - Weather forecast Seattle-Tacoma International Airport, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Seattle-Tacoma International Airport, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone place="3" zone-id="89639" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76524" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://seatacblog.com/2022/05/08/deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10/" aria-current="page">Deadline to apply for 2022 scholarship from Rotary Club of SeaTac-Tukwila is May 10</a>
</li>
<li>
<a href="https://seatacblog.com/2022/05/07/dubsea-fish-sticks-single-game-tickets-on-sale-now/">DubSea Fish Sticks single game tickets on sale now</a>
</li>
<li>
<a href="https://seatacblog.com/2022/05/06/seatac-business-forum-public-safety-series-will-be-thursday-may-19/">SeaTac Business Forum Public Safety Series will be Thursday, May 19</a>
</li>
<li>
<a href="https://seatacblog.com/2022/05/06/domestic-violence-shooting-suspect-arrested-in-seatac-after-region-wide-search/">Domestic Violence shooting suspect arrested in SeaTac after region-wide search</a>
</li>
<li>
<a href="https://seatacblog.com/2022/05/06/berkshire-hathaway-homeservices-northwest-real-estate-open-house-huntington-park-in-des-moines/">Berkshire Hathaway HomeServices Northwest Real Estate Open House: Huntington Park in Des Moines</a>
</li>
</ul>
</div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76512" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-25" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76513" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Poats</h4>
<ul class="wpp-list">
<li>
<a href="https://seatacblog.com/2020/03/14/starting-monday-all-city-of-seatac-facilities-will-be-closed-due-to-coronavirus-outbreak/" class="wpp-post-title" target="_self">Starting Monday, all City of SeaTac facilities will be closed due to coronavirus outbreak</a>
<span class="wpp-meta post-stats"><span class="wpp-views">20.9k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/13/city-of-seatac-issues-proclamation-of-emergency-due-to-covid-19/" class="wpp-post-title" target="_self">City of SeaTac issues &#8216;Proclamation of Emergency&#8217; due to COVID-19</a>
<span class="wpp-meta post-stats"><span class="wpp-views">10.6k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/06/city-of-seatac-releases-statement-on-covid-19-coronavirus/" class="wpp-post-title" target="_self">City of SeaTac releases statement on COVID-19 Coronavirus</a>
<span class="wpp-meta post-stats"><span class="wpp-views">7k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/01/25/photos-videos-huge-walkway-installed-at-sea-tac-airports-international-arrivals-facility/" class="wpp-post-title" target="_self">PHOTOS/VIDEOS: Huge walkway installed at Sea-Tac Airport&#8217;s International Arrivals Facility</a>
<span class="wpp-meta post-stats"><span class="wpp-views">6.5k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/" class="wpp-post-title" target="_self">King County will turn Quality Inn hotel in SeaTac into temp shelter for homeless</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.5k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/11/05/election-results-1-anderson-kwon-tombs-and-sitterley-have-early-leads/" class="wpp-post-title" target="_self">ELECTION RESULTS 1: Anderson, Kwon, Tombs and Sitterley have early leads</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.8k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/09/19/two-killed-in-horrific-collision-in-seatac-wednesday-night/" class="wpp-post-title" target="_self">Two killed in horrific collision in SeaTac Wednesday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.7k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Enrique Vasquez</span> on <a href="https://seatacblog.com/2022/01/16/man-killed-trying-to-cross-sr-518-in-seatac-wednesday-night/#comment-72349">Man killed trying to cross SR 518 in SeaTac Saturday night</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://Seatac%20Blog' rel='external nofollow ugc' class='url'>Leona</a></span> on <a href="https://seatacblog.com/2022/02/28/letter-to-the-editor-i-am-disappointed-with-our-seatac-mayor/#comment-68497">LETTER TO THE EDITOR: &#8216;I am disappointed with our SeaTac Mayor&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Chuck darielli</span> on <a href="https://seatacblog.com/2022/02/28/letter-to-the-editor-i-am-disappointed-with-our-seatac-mayor/#comment-67869">LETTER TO THE EDITOR: &#8216;I am disappointed with our SeaTac Mayor&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Pam Fernald</span> on <a href="https://seatacblog.com/2022/02/28/letter-to-the-editor-i-am-disappointed-with-our-seatac-mayor/#comment-67795">LETTER TO THE EDITOR: &#8216;I am disappointed with our SeaTac Mayor&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Editor</span> on <a href="https://seatacblog.com/2022/02/15/heres-how-you-can-get-a-free-yard-tree-from-communitrees/#comment-66251">Here&#8217;s how you can get a free yard tree from CommuniTrees</a></li></ul></div> <div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76518" keywords="not_home_page,not_landing_page,is_article_page,education,featured-post,news,non-profit,seatac,seatacnews,deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','education','featured-post','news','non-profit','seatac','seatacnews','deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["education","featured-post","news","non-profit","seatac","seatacnews","deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10","post"],"url":"deadline-to-apply-for-2022-scholarship-from-rotary-club-of-seatac-tukwila-is-may-10"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script><div style="position:fixed;bottom:0px;right:8%;z-index:999999;" id="gtranslate_wrapper">
<style>
.switcher {font-family:Arial;font-size:12pt;text-align:left;cursor:pointer;overflow:hidden;width:173px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:12pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#fff linear-gradient(180deg, #efefef 0%, #fff 70%);position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #ccc;color:#666;padding:3px 5px;width:161px;}
.switcher .selected a:after {height:24px;display:inline-block;position:absolute;right:10px;width:15px;background-position:50%;background-size:11px;background-image:url("data:image/svg+xml;utf8,<svg xmlns='http://www.w3.org/2000/svg' width='16' height='16' viewBox='0 0 285 285'><path d='M282 76.5l-14.2-14.3a9 9 0 0 0-13.1 0L142.5 174.4 30.3 62.2a9 9 0 0 0-13.2 0L3 76.5a9 9 0 0 0 0 13.1l133 133a9 9 0 0 0 13.1 0l133-133a9 9 0 0 0 0-13z' style='fill:%23666'/></svg>");background-repeat:no-repeat;content:""!important;transition:all .2s;}
.switcher .selected a.open:after {-webkit-transform: rotate(-180deg);transform:rotate(-180deg);}
.switcher .selected a:hover {background:#fff}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #ccc;border-right:1px solid #ccc;border-bottom:1px solid #ccc;background-color:#eee;display:none;width:171px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#fff;}
.switcher .option a.selected {background:#fff;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#f5f5f5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/es-mx.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|uk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ukrainian" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/uk.png" height="24" width="24" alt="uk" /> Ukrainian</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script>
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style>#goog-gt-tt{display:none!important;}.goog-te-banner-frame{display:none!important;}.goog-te-menu-value:hover{text-decoration:none!important;}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important;}body{top:0!important;}#google_translate_element2{display:none!important;}</style>
<div id="google_translate_element2"></div>
<script>function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script>
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
<script>(function gt_jquery_ready() {if(!window.jQuery||!jQuery.fn.click) return setTimeout(gt_jquery_ready, 20);jQuery(document).ready(function() {var allowed_languages = ["zh-CN","en","it","es","uk","vi"];var accept_language = navigator.language.toLowerCase() || navigator.userLanguage.toLowerCase();switch(accept_language) {case 'zh-cn': var preferred_language = 'zh-CN'; break;case 'zh': var preferred_language = 'zh-CN'; break;case 'zh-tw': var preferred_language = 'zh-TW'; break;case 'zh-hk': var preferred_language = 'zh-TW'; break;case 'he': var preferred_language = 'iw'; break;default: var preferred_language = accept_language.substr(0, 2); break;}if(preferred_language != 'en' && GTranslateGetCurrentLang() == null && document.cookie.match('gt_auto_switch') == null && allowed_languages.indexOf(preferred_language) >= 0){doGTranslate('en|'+preferred_language);document.cookie = 'gt_auto_switch=1; expires=Thu, 05 Dec 2030 08:08:08 UTC; path=/;';var lang_html = jQuery('div.switcher div.option').find('img[alt="'+preferred_language+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));}});})();</script></div> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHDHPPP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<link rel='stylesheet' id='tec-variables-skeleton-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-skeleton.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-skeleton-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-skeleton.min.css?ver=5.14.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tec-variables-full-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-full.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-full-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-full.min.css?ver=4.14.18.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-full-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-full.min.css?ver=5.14.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-global-functions.js?ver=2.27.4' id='et-builder-modules-global-functions-script-js'></script>
<script type='text/javascript' id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type='text/javascript' async src='https://clientcdn.pushengage.com/core/e960d6fd-bcdb-493b-b5a9-b537661ab0bf.js?ver=5.9.3' id='pushengage-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/jquery/ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/smoothscroll.js?ver=2.27.4' id='smooth-scroll-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/masonry.min.js' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"a473d7a393","timeline_nonce":"4ef5199672","blog_feed_nonce":"07cad919ba","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/scripts.js?ver=2.27.4' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/jquery.raty.js?ver=2.27.4' id='raty-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.fitvids.js?ver=2.27.4' id='divi-fitvids-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/waypoints.min.js?ver=2.27.4' id='waypoints-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.magnific-popup.js?ver=2.27.4' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.mobile.custom.min.js?ver=2.27.4' id='et-jquery-touch-mobile-js'></script>
<script type='text/javascript' id='et-builder-modules-script-js-extra'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"c09157a2a0","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"94f4b3d3a4","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"141291","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-scripts.js?ver=2.27.4' id='et-builder-modules-script-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/core/admin/js/common.js?ver=3.27.4' id='et-core-common-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=4.14.18.1' id='tribe-common-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/utils/query-string.js?ver=4.14.18.1' id='tribe-query-string-js'></script>
<script src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9.3/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script defer type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/manager.js?ver=5.14.2.1' id='tribe-events-views-v2-manager-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/breakpoints.js?ver=5.14.2.1' id='tribe-events-views-v2-breakpoints-js'></script>
<script src='https://stats.wp.com/e-202218.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'186871394',post:'141291',tz:'-7',srv:'seatacblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '186871394', '141291' ]);
</script>
</body>
</html>
