<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://seatacblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://seatacblog.com';var et_post_id='140720';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>It’s official – former Highline Bears baseball team is now the ‘Dub Sea Fish Sticks’! | The SeaTac Blog</title>

<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The SeaTac Blog | SeaTac News, Crime, COVID-19, Events, Politics &amp; more" />
<meta property="og:type" content="article" />
<meta property="og:title" content="It’s official – former Highline Bears baseball team is now the ‘Dub Sea Fish Sticks’! | The SeaTac Blog" />
<meta property="og:url" content="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/" />
<meta property="article:published_time" content="2021-12-02T23:32:32+00:00" />
<meta property="article:modified_time" content="2021-12-02T23:32:32+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/seatacblog" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@theseatacblog" />
<meta name="twitter:domain" content="seatacblog.com" />
<meta name="twitter:title" content="It’s official – former Highline Bears baseball team is now the ‘Dub Sea Fish Sticks’! | The SeaTac Blog" />
<meta name="twitter:creator" content="@theseatacblog" />

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Feed" href="https://seatacblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Comments Feed" href="https://seatacblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The SeaTac Blog &raquo; iCal Feed" href="https://seatacblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;! Comments Feed" href="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/seatacblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://seatacblog.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://seatacblog.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://seatacblog.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://seatacblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://seatacblog.com/wp-content/themes/Extra-2/style.dev.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css' href='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/styles/magnific_popup.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://seatacblog.com/wp-includes/css/dashicons.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://seatacblog.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.3' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210930' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.8.2' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts","ID":140720,"token":"143fa202f5","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.0' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://seatacblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seatacblog.com/wp-json/wp/v2/posts/140720" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seatacblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seatacblog.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://seatacblog.com/?p=140720' />
<link rel="alternate" type="application/json+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2021%2F12%2F02%2Fits-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2021%2F12%2F02%2Fits-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks%2F&#038;format=xml" />
<meta property="fb:pages" content="293605064226" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://seatacblog.com"><link rel="https://theeventscalendar.com/" href="https://seatacblog.com/wp-json/tribe/events/v1/" /> <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://seatacblog.com/wp-content/uploads/2020/09/STBFavicon.jpg" /><link rel="amphtml" href="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/?amp">
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHDHPPP');</script>

<script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE SEATAC BLOG...').css('opacity','1'); 
});
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20430280-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20430280-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=VM5WbNEfwY9oXPbxN3ihiy5E";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://seatacblog.com/wp-content/cache/et/global/et-extra-customizer-global-163734405346.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-140720 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fixed_nav et_smooth_scroll et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-138191" class="et-trending-post et-trending-latest">
<a href="https://seatacblog.com/2019/10/31/letter-a-statement-from-seatac-city-council-candidate-takele-gobena/">LETTER: A statement from SeaTac City Council candidate ...</a>
</div>
<div id="et-trending-post-138718" class="et-trending-post">
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/">King County will turn Quality Inn hotel in SeaTac into ...</a>
 </div>
<div id="et-trending-post-139049" class="et-trending-post">
<a href="https://seatacblog.com/2020/07/06/king-county-sheriff-issues-statement-regarding-offensive-facebook-posts/">King County Sheriff issues statement regarding offensiv...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://seatacblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://seatacblog.com/" data-fixed-height="51">
<img src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" alt="The SeaTac Blog" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-136055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-136055"><a href="https://seatacblog.com">Home</a></li>
<li id="menu-item-136190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136190"><a href="https://seatacblog.com/category/crime/">Crime</a></li>
<li id="menu-item-140620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140620"><a href="https://seatacblog.com/category/politics/">Politics</a></li>
<li id="menu-item-136174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136174"><a href="https://seatacblog.com/events/">Events</a></li>
<li id="menu-item-136059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136059"><a href="https://seatacblog.com/jobs/">Jobs</a></li>
<li id="menu-item-137992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137992"><a href="https://seatacblog.com/category/business/">Business</a></li>
<li id="menu-item-137987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137987"><a href="https://seatacblog.com/weather/">Weather</a></li>
<li id="menu-item-140120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140120"><a href="https://seatacblog.com/webcams/">Webcams</a></li>
<li id="menu-item-138757" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-138757"><a href="https://seatacblog.com/category/COVID-19/">COVID-19</a></li>
<li id="menu-item-137986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137986"><a href="https://seatacblog.com/advertise/">Advertise</a></li>
<li id="menu-item-136062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136062"><a href="https://seatacblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136264"><a href="https://seatacblog.com/about/">About</a></li>
<li id="menu-item-139251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139251"><a href="https://seatacblog.com/support-local-journalism/">Support Local Journalism</a></li>
<li id="menu-item-139056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139056"><a href="https://seatacblog.com/subscribe-to-our-daily-digest-email-newsletter/">Subscribe to our Daily Digest Email Newsletter</a></li>
<li id="menu-item-136061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136061"><a href="https://seatacblog.com/contact/">Contact</a></li>
<li id="menu-item-136060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136060"><a href="https://seatacblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-138478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-138478"><a href="https://seatacblog.com/privacy-policy-terms/">Privacy Policy/Terms</a></li>
</ul>
</li>
<li id="menu-item-140208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-140208"><a href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2019/10/BHHSLogoforMenu167x69.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="152" height="52"></a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-140720" class="module single-post-module post-140720 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-featured-post category-news category-seatac category-seatacnews category-sports tag-baseball tag-dub-sea-fish-sticks tag-highline-bears tag-news tag-seatac tag-white-center et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!</h1>
<div class="post-meta vcard">
<p><span class="updated">Dec 2, 2021</span> | <a href="https://seatacblog.com/category/entertainment/" rel="tag">Entertainment</a>, <a href="https://seatacblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://seatacblog.com/category/news/" rel="tag">News</a>, <a href="https://seatacblog.com/category/seatac/" rel="tag">SeaTac</a>, <a href="https://seatacblog.com/category/seatacnews/" rel="tag">SeaTac News</a>, <a href="https://seatacblog.com/category/sports/" rel="tag">Sports</a> | <a class="comments-link" href="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://seatacblog.com/wp-content/uploads/2021/12/SKM-DubSeaFishSticks2021Logo-1280x640.jpg" alt="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>On Thursday morning, Dec. 2, 2021, officials from the formerly Highline Bears baseball team held a press conference at the Edgewater Hotel to reveal the team&#8217;s new name – the Dub Sea Fish Sticks.</strong></p>
<p><a href="https://b-townblog.com/wp-content/uploads/2021/12/DubSeaFishSticksLogo-2.jpg"><img loading="lazy" class="aligncenter size-full wp-image-154295" src="https://b-townblog.com/wp-content/uploads/2021/12/DubSeaFishSticksLogo-2.jpg" alt="" width="531" height="604" /></a></p>
<p>After months of anticipation, over 5,000 votes from every state in the country, and from 7 different countries around the world, the &#8216;Fish Sticks&#8217; won the team&#8217;s renaming contest by less than 1% with 50.47% of the total vote.</p>
<p>&#8220;But there&#8217;s a silver lining for Seal Slinger fans,&#8221; General Manager Justin Moser said. &#8220;We&#8217;ll have a Seal Slinger section at every game so you can wear your gear and actively protest while you cheer on the team. If you&#8217;ve already ordered Seal Slinger merch, don&#8217;t worry, it&#8217;s still on the way. You now own a limited edition piece of merchandise.&#8221;</p>
<p><a href="https://b-townblog.com/wp-content/uploads/2021/12/TheFryerLogo.jpg"><img loading="lazy" class="alignright  wp-image-154298" src="https://b-townblog.com/wp-content/uploads/2021/12/TheFryerLogo-300x224.jpg" alt="" width="300" height="224" /></a>The newly re-named Dub Sea Fish Sticks are a summer collegiate baseball team based out of White Center at Mel Olson Stadium at Steve Cox Memorial Stadium. They will refer to their stadium now as &#8220;<strong>The Fryer</strong>.&#8221;</p>
<p>And yes, this newly-named team will apparently sell Fish Sticks at their home games, with their first pitch expected on June 4, 2022.</p>
<p>&#8220;The Dub Sea Fish Sticks are more than a baseball team. We’re a fun experience for the whole family. This is an event you won’t want to miss!!&#8221;</p>
<p>The team hosts college players from around the country for the months of June, July and the first week in August.</p>
<p>&#8220;The team prides itself on being community focused offering fun, affordable family entertainment all summer long,&#8221; Moser said.</p>
<p>The Fish Sticks host between 25-30 games per summer at their ballpark, with regular theme nights, promotions, and a variety of other off field entertainment nightly. Tickets to games are affordable ranging between $8-$12 per person. Fans interested in going to games can join a priority ticket list to be notified directly when tickets go on sale. Opening Night for the 2022 summer season is scheduled for Saturday, June 4, 2022.</p>
<p><strong>Stadium History</strong><br />
White Center Stadium was built in the Summer of 1940 and would soon become the center of the communities’ entertainment. The full wooden stadium held upwards of 2,000 people on Friday and Saturday nights, usually overflowing with people down the left and right field lines.</p>
<p>Kids would attend the games, running in and out of the stadium. Inside they would watch their heroes, and outside they would play on the small field #2, in the shadow of the lights from the main stadium. They would ask their parents for money to get something from the snack shack and would watch baseball day and night during the summer months. When not watching or playing baseball, kids would play on the playground outside the left field fence, known as “Astroland.”</p>
<p>Late in the evening on May 22, 1977 the historic White Center Stadium caught fire, and black smoke could be seen from miles away. The local fire department responded but it was too late. The flames engulfed the beloved stadium, and all they could do was drive out on to the infield and open the hoses to put the fire out.</p>
<p>After the fire, community baseball became somewhat of a memory at White Center Stadium. But one man was determined to replace the stadium, his name was Mel Olson. Head of the White Center Chamber of Commerce and the man responsible for starting Southwest Little League, Olson relentlessly campaigned for to rebuild the stadium. Initial bids came in thirty percent over what was available. Finally in late 1978, with the help of King County Councilman Bob Greive, and funds from the Forward Thrust Fund the stadium was rebuilt, this time with concrete and metal bleachers. The new stadium Opened on April 2, 1979. In the summer of 1985 the stadium was renamed after Mel Olson. Mel Olson stadium now seats 1,100 people. Baseball was never the same in the area, teams would still use the stadium but it was never packed like it had been. The stadium was on the decline with little to no maintenance or improvements to the field for twenty plus years.</p>
<p>In 2008, King County Parks, Seattle Prep High School, King County Sheriffs and the Puget Sound Senior Baseball League, Seattle Mariners, along with many other groups and volunteers organized a remodel of the field. They dedicated the park to long time community leader and slain officer, Steve Cox.</p>
<p>Today the Mel Olson Stadium inside of Steve Cox Memorial Park is used by Seattle Prep High School, South West Little League, select baseball programs, and the PSSBL to name a few. The Dub Sea Fish Sticks brought back summer collegiate baseball to the community in the summer of 2015. Drawing average crowds between 250-400 fans with attendance nearing 600 on Friday and Saturday evenings.</p>
<p><strong>VIDEO</strong><br />
Here&#8217;s video of Thursday morning&#8217;s &#8220;big reveal&#8221; press conference announcement, hosted by General Manager Justin Moser:</p>
<p><center><iframe loading="lazy" style="border: none; overflow: hidden;" src="https://www.facebook.com/plugins/video.php?height=314&amp;href=https%3A%2F%2Fwww.facebook.com%2Fhighlinebears%2Fvideos%2F427883882136015%2F&amp;show_text=true&amp;width=560&amp;t=0" width="560" height="429" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe></center>More info at <a href="https://gofishsticks.com" target="_blank" rel="noopener"><strong>https://gofishsticks.com</strong></a>.</p>

<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get more local SeaTac News FREE by email every day at 6pm!</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_202290995'><broadstreet-zone callback="zone_load_202290995" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_202290995 = function(z, d) { if (!d.count) document.getElementById('zone_load_202290995').style.display = 'none'; };</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/&#038;t=It%E2%80%99s%20official%20%E2%80%93%20former%20Highline%20Bears%20baseball%20team%20is%20now%20the%20%E2%80%98Dub%20Sea%20Fish%20Sticks%E2%80%99%21" class="social-share-link" title="Share &quot;It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!&quot; via Facebook" data-network-name="facebook" data-share-title="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" data-share-url="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=It%E2%80%99s%20official%20%E2%80%93%20former%20Highline%20Bears%20baseball%20team%20is%20now%20the%20%E2%80%98Dub%20Sea%20Fish%20Sticks%E2%80%99%21%20https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/" class="social-share-link" title="Share &quot;It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!&quot; via Twitter" data-network-name="twitter" data-share-title="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" data-share-url="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/&#038;title=It%E2%80%99s%20official%20%E2%80%93%20former%20Highline%20Bears%20baseball%20team%20is%20now%20the%20%E2%80%98Dub%20Sea%20Fish%20Sticks%E2%80%99%21" class="social-share-link" title="Share &quot;It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!&quot; via LinkedIn" data-network-name="linkedin" data-share-title="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" data-share-url="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!&quot; via Email" data-network-name="basic_email" data-share-title="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" data-share-url="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!&quot; via Print" data-network-name="basic_print" data-share-title="It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!" data-share-url="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #8bd623;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://seatacblog.com/2021/12/01/reminder-kennedy-catholic-high-school-arts-and-crafts-fair-is-this-saturday-dec-4/" rel="prev"><span class="button">Previous</span><span class="title">REMINDER: Kennedy Catholic High School Arts and Crafts Fair is this Saturday, Dec. 4</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://seatacblog.com/wp-comments-post.php?wpe-comment-post=seatacblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='140720' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4d97bc6721" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="104" /><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://seatacblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76520" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="tribe-events-list-widget-3" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-140658 tribe-clearfix tribe-events-venue-138289 tribe-events-organizer-139869">

<h4 class="tribe-event-title">
<a href="https://seatacblog.com/event/seatacs-annual-tree-lighting-will-be-friday-dec-3/" rel="bookmark">SeaTac&#8217;s annual Tree Lighting will be Friday, Dec. 3</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">December 3 @ 5:00 pm</span> - <span class="tribe-event-time">6:30 pm</span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="https://seatacblog.com/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"SeaTac&#8217;s annual Tree Lighting will be Friday, Dec. 3","description":"&lt;p&gt;The City of SeaTac is bringing back its annual Tree Lighting and Festive Fun event on Friday, Dec. 3, 2021. The event will look a little different from previous years, and the city will be moving the event outside. The event starts at 5 p.m., with the Tree Lighting at 5:45 p.m. The SeaTac Community [&hellip;]&lt;/p&gt;\\n","url":"https://seatacblog.com/event/seatacs-annual-tree-lighting-will-be-friday-dec-3/","startDate":"2021-12-03T17:00:00-08:00","endDate":"2021-12-03T18:30:00-08:00","location":{"@type":"Place","name":"SeaTac Community Center","description":"","url":"","address":{"@type":"PostalAddress","streetAddress":"13735 24th Ave. South","addressLocality":"SeaTac","addressRegion":"WA","postalCode":"98168","addressCountry":"United States"},"telephone":"","sameAs":""},"organizer":{"@type":"Person","name":"City of SeaTac","description":"","url":"https://www.seatacwa.gov","telephone":"","email":"","sameAs":"https://www.seatacwa.gov"},"performer":"Organization"}]
</script><div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://seatacblog.com/support-local-journalism/"><img width="300" height="250" src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="image wp-image-139276  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div> <div id="bs_zones-19" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78564" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://seatacblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe to our Daily Email Newsletter</h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our Daily Digest Email Newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> <div id="bs_zones-18" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#336666;border:1px solid #225555;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #225555'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Seattle-Tacoma International Airport</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-11'></i><span class='temp'>43°</span><div class='current_text'>Rain Shower</div><div class='sunrise_sunset'>7:37am<i class='wi wi-fw wi-weather-32'></i>4:20pm PST</div></div><span class='current_text_2'>Feels like: 37<small>°F</small><br />Wind: 8<small>mph</small> NNE<br />Humidity: 79<small>%</small><br />Pressure: 30.31<small>"Hg</small><br />UV index: 0</span><div class='daily days' style='border-bottom:1px solid #225555'><span class='extended_day extended_day_1'>Fri</span><span class='extended_day extended_day_2'>Sat</span><span class='extended_day extended_day_3'>Sun</span><span class='extended_day extended_day_4'>Mon</span><span class='extended_day extended_day_5'>Tue</span></div><div class='daily'><span class='extended_day extended_day_1' title='Cloudy'>43/36<small>°F</small><br /><i class='wi wi-fw wi-weather-26'></i></span><span class='extended_day extended_day_2' title='AM Light Rain'>41/32<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_3' title='Cloudy'>39/34<small>°F</small><br /><i class='wi wi-fw wi-weather-26'></i></span><span class='extended_day extended_day_4' title='AM Rain'>41/32<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_5' title='Mostly Cloudy'>41/37<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #225555'><a href='https://www.weather-atlas.com/en/washington-usa/seattle-tacoma-international-airport' title='Weather Atlas - Weather forecast Seattle-Tacoma International Airport, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Seattle-Tacoma International Airport, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone place="3" zone-id="89639" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76524" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76512" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://seatacblog.com/2021/12/02/its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks/" aria-current="page">It&#8217;s official – former Highline Bears baseball team is now the &#8216;Dub Sea Fish Sticks&#8217;!</a>
</li>
<li>
<a href="https://seatacblog.com/2021/12/01/reminder-kennedy-catholic-high-school-arts-and-crafts-fair-is-this-saturday-dec-4/">REMINDER: Kennedy Catholic High School Arts and Crafts Fair is this Saturday, Dec. 4</a>
</li>
<li>
<a href="https://seatacblog.com/2021/12/01/jake-simpson-sworn-in-as-newest-seatac-city-councilmember/">Jake Simpson sworn in as newest SeaTac City Councilmember</a>
</li>
<li>
<a href="https://seatacblog.com/2021/12/01/seattle-southside-chamber-shop-small-win-big/">Seattle Southside Chamber: Shop Small, Win Big</a>
</li>
<li>
<a href="https://seatacblog.com/2021/11/29/video-locals-share-plan-b-stories-at-7-stories-event-at-highline-heritage-museum/">VIDEO: Locals share &#8216;Plan B&#8217; stories at 7 Stories event at Highline Heritage Museum</a>
</li>
</ul>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Poats</h4>
<ul class="wpp-list">
<li>
<a href="https://seatacblog.com/2020/03/14/starting-monday-all-city-of-seatac-facilities-will-be-closed-due-to-coronavirus-outbreak/" class="wpp-post-title" target="_self">Starting Monday, all City of SeaTac facilities will be closed due to coronavirus outbreak</a>
<span class="wpp-meta post-stats"><span class="wpp-views">20.7k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/13/city-of-seatac-issues-proclamation-of-emergency-due-to-covid-19/" class="wpp-post-title" target="_self">City of SeaTac issues &#8216;Proclamation of Emergency&#8217; due to COVID-19</a>
<span class="wpp-meta post-stats"><span class="wpp-views">10.4k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/06/city-of-seatac-releases-statement-on-covid-19-coronavirus/" class="wpp-post-title" target="_self">City of SeaTac releases statement on COVID-19 Coronavirus</a>
<span class="wpp-meta post-stats"><span class="wpp-views">6.8k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/01/25/photos-videos-huge-walkway-installed-at-sea-tac-airports-international-arrivals-facility/" class="wpp-post-title" target="_self">PHOTOS/VIDEOS: Huge walkway installed at Sea-Tac Airport&#8217;s International Arrivals Facility</a>
<span class="wpp-meta post-stats"><span class="wpp-views">6.2k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/" class="wpp-post-title" target="_self">King County will turn Quality Inn hotel in SeaTac into temp shelter for homeless</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.1k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/11/05/election-results-1-anderson-kwon-tombs-and-sitterley-have-early-leads/" class="wpp-post-title" target="_self">ELECTION RESULTS 1: Anderson, Kwon, Tombs and Sitterley have early leads</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.7k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/09/19/two-killed-in-horrific-collision-in-seatac-wednesday-night/" class="wpp-post-title" target="_self">Two killed in horrific collision in SeaTac Wednesday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.6k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Kevin</span> on <a href="https://seatacblog.com/2021/12/01/jake-simpson-sworn-in-as-newest-seatac-city-councilmember/#comment-54433">Jake Simpson sworn in as newest SeaTac City Councilmember</a></li><li class="recentcomments"><span class="comment-author-link">Sebastian martinez</span> on <a href="https://seatacblog.com/2021/11/12/what-are-you-looking-for-in-highline-public-schools-next-superintendent/#comment-54420">What are you looking for in Highline Public Schools’ next superintendent?</a></li><li class="recentcomments"><span class="comment-author-link">Darlene Wolf</span> on <a href="https://seatacblog.com/2021/11/18/rep-smith-introduces-bill-to-address-aviation-noise-emissions/#comment-53618">Rep. Smith introduces bill to address aviation noise &#038; emissions</a></li><li class="recentcomments"><span class="comment-author-link">Rebecca Doyle</span> on <a href="https://seatacblog.com/2021/10/20/seatac-fall-recycling-event-will-be-this-saturday-oct-23-near-valley-ridge-park/#comment-52476">SeaTac Fall Recycling Event will be this Saturday, Oct. 23 near Valley Ridge Park/Tyee</a></li><li class="recentcomments"><span class="comment-author-link">cindy l gailey</span> on <a href="https://seatacblog.com/2021/09/16/seatac-council-meeting-tuesday-ends-with-mayor-sitterley-muting-councilmember-gobena-over-his-comments/#comment-48720">SeaTac Council meeting Tuesday ends with Mayor Sitterley muting Councilmember Gobena over his comments</a></li></ul></div> <div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76518" keywords="not_home_page,not_landing_page,is_article_page,entertainment,featured-post,news,seatac,seatacnews,sports,its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','entertainment','featured-post','news','seatac','seatacnews','sports','its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["entertainment","featured-post","news","seatac","seatacnews","sports","its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks","post"],"url":"its-official-former-highline-bears-baseball-team-is-now-the-dub-sea-fish-sticks"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHDHPPP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<link rel='stylesheet' id='tribe-events-custom-jquery-styles-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=5.12.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=5.12.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css?ver=5.12.0' type='text/css' media='all' />
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-global-functions.js?ver=2.27.4' id='et-builder-modules-global-functions-script-js'></script>
<script type='text/javascript' id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type='text/javascript' async src='https://clientcdn.pushengage.com/core/e960d6fd-bcdb-493b-b5a9-b537661ab0bf.js?ver=5.8.2' id='pushengage-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/dom-ready.min.js?ver=71883072590656bf22c74c7b887df3dd' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/hooks.min.js?ver=a7edae857aab69d69fa10d5aef23a5de' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/a11y.min.js?ver=0ac8327cc1c40dcfdf29716affd7ac63' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/smoothscroll.js?ver=2.27.4' id='smooth-scroll-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"4196bd28fa","timeline_nonce":"809c42f0d3","blog_feed_nonce":"892094bd08","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/scripts.js?ver=2.27.4' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/jquery.raty.js?ver=2.27.4' id='raty-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.fitvids.js?ver=2.27.4' id='divi-fitvids-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/waypoints.min.js?ver=2.27.4' id='waypoints-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.magnific-popup.js?ver=2.27.4' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.mobile.custom.min.js?ver=2.27.4' id='et-jquery-touch-mobile-js'></script>
<script type='text/javascript' id='et-builder-modules-script-js-extra'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"f525626f21","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"f5d5c35bf1","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"140720","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-scripts.js?ver=2.27.4' id='et-builder-modules-script-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/core/admin/js/common.js?ver=3.27.4' id='et-core-common-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202148.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'186871394',post:'140720',tz:'-8',srv:'seatacblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '186871394', '140720' ]);
</script>
</body>
</html>
