<!DOCTYPE html> <!--[if IE 6]><html id="ie6" lang="en-US"
 prefix="og: https://ogp.me/ns#" > <![endif]--> <!--[if IE 7]><html id="ie7" lang="en-US"
 prefix="og: https://ogp.me/ns#" > <![endif]--> <!--[if IE 8]><html id="ie8" lang="en-US"
 prefix="og: https://ogp.me/ns#" > <![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--><html lang="en-US" prefix="og: https://ogp.me/ns#"> <!--<![endif]--><head><meta charset="UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://seatacblog.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script> <![endif]--> <script type="text/javascript">document.documentElement.className = 'js';</script> <script>var et_site_url='https://seatacblog.com';var et_post_id='139526';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><link media="all" href="https://seatacblog.com/wp-content/cache/autoptimize/css/autoptimize_708f047917c2a14b5a098014a4fac2bd.css" rel="stylesheet" /><title>Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV | The SeaTac Blog</title><link rel="canonical" href="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/" /><meta property="og:site_name" content="The SeaTac Blog | SeaTac News, Crime, COVID-19, Events, Politics &amp; more" /><meta property="og:type" content="article" /><meta property="og:title" content="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV | The SeaTac Blog" /><meta property="og:url" content="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/" /><meta property="article:published_time" content="2020-12-31T19:12:34Z" /><meta property="article:modified_time" content="2020-12-31T19:12:34Z" /><meta property="twitter:card" content="summary" /><meta property="twitter:domain" content="seatacblog.com" /><meta property="twitter:title" content="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV | The SeaTac Blog" /><link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Feed" href="https://seatacblog.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Comments Feed" href="https://seatacblog.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="The SeaTac Blog &raquo; iCal Feed" href="https://seatacblog.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV Comments Feed" href="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/feed/" /> <script type="text/javascript" data-cfasync="false">(window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.14.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-20430280-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-20430280-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/seatacblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <meta content="Extra v.2.27.4" name="generator" /><link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.6' type='text/css' media='all' /><link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css' href='https://seatacblog.com/wp-includes/css/dashicons.min.css?ver=5.6' type='text/css' media='all' /> <script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/seatacblog.com","hash_tracking":"false"};</script> <script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.6' id='broadstreet-cdn-js'></script> <script type='application/json' id='wpp-json'>{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":139526,"token":"dc7940ed00","lang":0,"debug":0}</script> <link rel="https://api.w.org/" href="https://seatacblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seatacblog.com/wp-json/wp/v2/posts/139526" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seatacblog.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seatacblog.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://seatacblog.com/?p=139526' /><link rel="alternate" type="application/json+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2020%2F12%2F31%2Fdriver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv%2F" /><link rel="alternate" type="text/xml+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2020%2F12%2F31%2Fdriver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv%2F&#038;format=xml" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://seatacblog.com"><link rel="https://theeventscalendar.com/" href="https://seatacblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://seatacblog.com/wp-content/uploads/2020/09/STBFavicon.jpg" /><link rel="amphtml" href="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/?amp"><script>jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});</script> <script>jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE SEATAC BLOG...').css('opacity','1'); 
});</script> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-20430280-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20430280-1');</script> <script>(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=VM5WbNEfwY9oXPbxN3ihiy5E";
	fjs.parentNode.insertBefore(el, fjs);
}(document));</script> <div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://seatacblog.com/wp-content/cache/et/global/et-extra-customizer-global-160937127632.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head><body class="post-template-default single single-post postid-139526 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fixed_nav et_smooth_scroll et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<div id="page-container" class="page-container"><header class="header left-right"><div id="top-header" style=""><div class="container"><div id="et-secondary-nav" class="et-trending"><div id="et-trending"> <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a><h4 id="et-trending-label"> TRENDING:</h4><div id='et-trending-container'><div id="et-trending-post-138191" class="et-trending-post et-trending-latest"> <a href="https://seatacblog.com/2019/10/31/letter-a-statement-from-seatac-city-council-candidate-takele-gobena/">LETTER: A statement from SeaTac City Council candidate ...</a></div><div id="et-trending-post-139049" class="et-trending-post"> <a href="https://seatacblog.com/2020/07/06/king-county-sheriff-issues-statement-regarding-offensive-facebook-posts/">King County Sheriff issues statement regarding offensiv...</a></div><div id="et-trending-post-138202" class="et-trending-post"> <a href="https://seatacblog.com/2019/11/01/letter-learn-about-where-you-live-work-play-and-volunteer/">LETTER: &#8216;Learn about where you live, work, play a...</a></div></div></div></div><div id="et-info"><ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a></li></ul><div class="et-top-search" style=""><form role="search" class="et-search-form" method="get" action="https://seatacblog.com/"> <input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" /> <button class="et-search-submit"></button></form></div></div></div></div><div id="main-header-wrapper"><div id="main-header" data-fixed-height="80"><div class="container"> <a class="logo" href="https://seatacblog.com/" data-fixed-height="51"> <noscript><img src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" alt="The SeaTac Blog" /></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" alt="The SeaTac Blog" id="logo" /> </a><div id="et-navigation" class=""><ul id="et-menu" class="nav"><li id="menu-item-136055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-136055"><a href="https://seatacblog.com">Home</a></li><li id="menu-item-138757" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-138757"><a href="https://seatacblog.com/category/COVID-19/">COVID-19</a></li><li id="menu-item-136190" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-136190"><a href="https://seatacblog.com/category/crime/">Crime</a></li><li id="menu-item-136059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136059"><a href="https://seatacblog.com/jobs/">Jobs</a></li><li id="menu-item-137992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137992"><a href="https://seatacblog.com/category/business/">Business</a></li><li id="menu-item-136174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136174"><a href="https://seatacblog.com/events/">Events</a></li><li id="menu-item-137987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137987"><a href="https://seatacblog.com/weather/">Weather</a></li><li id="menu-item-137991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137991"><a href="https://seatacblog.com/coupons/">Coupons</a></li><li id="menu-item-137986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137986"><a href="https://seatacblog.com/advertise/">Advertise</a></li><li id="menu-item-136062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136062"><a href="https://seatacblog.com/about/">About</a><ul class="sub-menu"><li id="menu-item-136264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136264"><a href="https://seatacblog.com/about/">About</a></li><li id="menu-item-139251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139251"><a href="https://seatacblog.com/support-local-journalism/">Support Local Journalism</a></li><li id="menu-item-139056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139056"><a href="https://seatacblog.com/subscribe-to-our-daily-digest-email-newsletter/">Subscribe to our Daily Digest Email Newsletter</a></li><li id="menu-item-136061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136061"><a href="https://seatacblog.com/contact/">Contact</a></li><li id="menu-item-136060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136060"><a href="https://seatacblog.com/how-to-submit-to-the-blog/">How to submit</a></li><li id="menu-item-138478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-138478"><a href="https://seatacblog.com/privacy-policy-terms/">Privacy Policy/Terms</a></li></ul></li></ul><div id="et-mobile-navigation"> <span class="show-menu"><div class="show-menu-button"> <span></span> <span></span> <span></span></div><p>Select Page</p> </span><nav></nav></div></div></div></div></div></header><div id="main-content"><div class="container"><div id="content-area" class="clearfix"><div class="et_pb_extra_column_main"><center><em>If you appreciate our independent local journalism, please…</em><div class="pp-donate-button"></div></center><article id="post-139526" class="module single-post-module post-139526 post type-post status-publish format-standard has-post-thumbnail hentry category-burien category-crime category-featured-post category-news category-police category-seatac category-seatacnews tag-burien tag-chase tag-king-county-sheriffs-office tag-news tag-police tag-police-chase tag-pursuit tag-seatac tag-seatac-police-department et-has-post-format-content et_post_format-et-post-format-standard"><div class="post-header"><h1 class="entry-title">Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV</h1><div class="post-meta vcard"><p><span class="updated">Dec 31, 2020</span> | <a href="https://seatacblog.com/category/burien/" rel="tag">Burien</a>, <a href="https://seatacblog.com/category/crime/" rel="tag">Crime</a>, <a href="https://seatacblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://seatacblog.com/category/news/" rel="tag">News</a>, <a href="https://seatacblog.com/category/police/" rel="tag">Police</a>, <a href="https://seatacblog.com/category/seatac/" rel="tag">SeaTac</a>, <a href="https://seatacblog.com/category/seatacnews/" rel="tag">SeaTac News</a> | <a class="comments-link" href="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p></div></div><div class="post-thumbnail header"> <noscript><img src="https://seatacblog.com/wp-content/uploads/2020/12/SKM-KCSOChase123020-1280x640.jpg" alt="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" /></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://seatacblog.com/wp-content/uploads/2020/12/SKM-KCSOChase123020-1280x640.jpg" alt="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" /></div><div class="post-wrap"><div class="post-content entry-content"><p><strong>King County Sheriff&#8217;s Office deputies – with help from the Guardian One helicopter – safely ended a pursuit that traveled from SeaTac to Burien via Federal Way late Wednesday afternoon, Dec. 30, 2020.</strong></p><p>The chase ended around the 12400 block of 1st Ave South (map below).</p><p>Police say that the driver is in in custody for a felony domestic violence court order violation and other potential charges.</p><p>No persons, including two children in the SUV, were hurt.</p><p><center></p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">KCSO deputies, with help from Guardian One, safely ended a pursuit that traveled from SeaTac to Burien via Federal Way. The driver is in in-custody for a felony DV-court order violation and other potential charges. No persons, including two children in the SUV, were hurt. <a href="https://t.co/Vx34THmOJx">pic.twitter.com/Vx34THmOJx</a></p><p>&mdash; King County Sheriff&#39;s Office PIO (@kingcosoPIO) <a href="https://twitter.com/kingcosoPIO/status/1344466994096033794?ref_src=twsrc%5Etfw">December 31, 2020</a></p></blockquote><p> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2938.122080427599!2d-122.33632478436716!3d47.49164130390546!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x54904399c7242b7f%3A0xf9d0fbe359c0d7d7!2s12400%201st%20Ave%20S%2C%20Seattle%2C%20WA%2098168!5e1!3m2!1sen!2sus!4v1609441093228!5m2!1sen!2sus" width="600" height="450" frameborder="0" style="border:0;" allowfullscreen="" aria-hidden="false" tabindex="0"></iframe></center><br /> &nbsp;</p><link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"><div id="mc_embed_signup"><form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate><div id="mc_embed_signup_scroll"> <label for="mce-EMAIL">Get more local SeaTac News FREE by email every day at 6pm!</label> <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div></div></form></div><div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1648196945'><broadstreet-zone callback="zone_load_1648196945" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_1648196945 = function(z, d) { if (!d.count) document.getElementById('zone_load_1648196945').style.display = 'none'; };</script> </div></div><div class="post-footer"><div class="social-icons ed-social-share-icons"><p class="share-title">Share:</p> <a href="https://www.facebook.com/sharer.php?u=https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/&#038;t=Driver%20arrested%20after%20long%20police%20chase%20through%20SeaTac%20Wednesday%3B%202%20kids%20were%20inside%20SUV" class="social-share-link" title="Share &quot;Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV&quot; via Facebook" data-network-name="facebook" data-share-title="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" data-share-url="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/"> <span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span> </a><a href="https://twitter.com/intent/tweet?text=Driver%20arrested%20after%20long%20police%20chase%20through%20SeaTac%20Wednesday%3B%202%20kids%20were%20inside%20SUV%20https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/" class="social-share-link" title="Share &quot;Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV&quot; via Twitter" data-network-name="twitter" data-share-title="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" data-share-url="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/"> <span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span> </a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/&#038;title=Driver%20arrested%20after%20long%20police%20chase%20through%20SeaTac%20Wednesday%3B%202%20kids%20were%20inside%20SUV" class="social-share-link" title="Share &quot;Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" data-share-url="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/"> <span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV&quot; via Email" data-network-name="basic_email" data-share-title="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" data-share-url="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/"> <span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV&quot; via Print" data-network-name="basic_print" data-share-title="Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV" data-share-url="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/"> <span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span> </a></div></div></article><nav class="post-nav"><div class="nav-links clearfix"><div class="nav-link nav-link-prev"> <a href="https://seatacblog.com/2020/12/30/number-of-wa-notify-users-tops-1-5-million-exceeds-25-of-adults-in-state/" rel="prev"><span class="button">Previous</span><span class="title">Number of WA Notify users tops 1.5 million, exceeds 25% of adults in state</span></a></div><div class="nav-link nav-link-next"> <a href="https://seatacblog.com/2020/12/31/hi-liners-new-reimagined-emma-a-pop-musical-is-created-out-of-the-zoom-box/" rel="next"><span class="button">Next</span><span class="title">Hi-Liners new, reimagined &#8216;Emma: A Pop Musical&#8217; is created out of the (Zoom) box</span></a></div></div></nav>  <center><em>If you appreciate our independent local journalism, please…</em><div class="pp-donate-button"></div></center><section id="comment-wrap"><div id="comments" class="nocomments"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://seatacblog.com/wp-comments-post.php?wpe-comment-post=seatacblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='139526' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="bc52b8ec46" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="134" /></p></form></div></section></div><div class="et_pb_extra_column_sidebar"><div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"></h4><form role="search" method="get" class="search-form" action="https://seatacblog.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></div><div id="bs_zones-9" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76520" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://seatacblog.com/support-local-journalism/"><noscript><img width="300" height="250" src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="image wp-image-139276  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></noscript><img width="300" height="250" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="lazyload image wp-image-139276  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" /></a></div><div id="bs_zones-19" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78564" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4><div class="textwidget"><p><a href="https://seatacblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><noscript><img class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></noscript><img class="lazyload aligncenter size-full wp-image-147112" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20150%22%3E%3C/svg%3E' data-src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p></div></div><div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe to our Daily Email Newsletter</h4><div class="textwidget custom-html-widget"><link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"><div id="mc_embed_signup"><form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate><div id="mc_embed_signup_scroll"> <label for="mce-EMAIL">Subscribe to our Daily Digest Email Newsletter</label> <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div></div></form></div></div></div><div id="bs_zones-18" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#336666;border:1px solid #225555;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #225555'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Seattle-Tacoma International Airport</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>var weather_atlas_language = 'en';</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-11'></i><span class='temp'>48°</span><div class='current_text'>Light Rain</div><div class='sunrise_sunset'>7:56am<i class='wi wi-fw wi-weather-32'></i>4:30pm PST</div></div><span class='current_text_2'>Feels like: 43<small>°F</small><br />Wind: 18<small>mph</small> S<br />Humidity: 81<small>%</small><br />Pressure: 29.86<small>"Hg</small><br />UV index: 0</span><div class='daily days' style='border-bottom:1px solid #225555'><span class='extended_day extended_day_1'>Sun</span><span class='extended_day extended_day_2'>Mon</span><span class='extended_day extended_day_3'>Tue</span><span class='extended_day extended_day_4'>Wed</span><span class='extended_day extended_day_5'>Thu</span></div><div class='daily'><span class='extended_day extended_day_1' title='AM Showers'>48/43<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_2' title='Rain'>48/41<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_3' title='Showers'>50/45<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_4' title='Rain'>50/43<small>°F</small><br /><i class='wi wi-fw wi-weather-12'></i></span><span class='extended_day extended_day_5' title='AM Showers'>50/41<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #225555'><a href='https://www.weather-us.com/en/washington-usa/seattle-tacoma-international-airport' title='Weather Atlas - Weather forecast Seattle-Tacoma International Airport, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Seattle-Tacoma International Airport, Washington &#9656;</span></a></div></div></div><div id="bs_zones-13" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76523" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76524" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76512" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="recent-posts-2" class="et_pb_widget widget_recent_entries"><h4 class="widgettitle">Recent Posts</h4><ul><li> <a href="https://seatacblog.com/2021/01/01/annual-empty-bowls-fundraiser-will-be-all-virtual-this-year-from-jan-15-29/">Annual Empty Bowls fundraiser will be all virtual this year, from Jan. 15–29</a></li><li> <a href="https://seatacblog.com/2021/01/01/charges-filed-against-julius-t-booth-for-kidnapping-dv-plus-dash-cam-video/">Charges filed against Julius T. Booth for kidnapping, DV &#038; eluding police; plus dash cam video</a></li><li> <a href="https://seatacblog.com/2020/12/31/hi-liners-new-reimagined-emma-a-pop-musical-is-created-out-of-the-zoom-box/">Hi-Liners new, reimagined &#8216;Emma: A Pop Musical&#8217; is created out of the (Zoom) box</a></li><li> <a href="https://seatacblog.com/2020/12/31/driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv/" aria-current="page">Driver arrested after long police chase through SeaTac Wednesday; 2 kids were inside SUV</a></li><li> <a href="https://seatacblog.com/2020/12/30/number-of-wa-notify-users-tops-1-5-million-exceeds-25-of-adults-in-state/">Number of WA Notify users tops 1.5 million, exceeds 25% of adults in state</a></li></ul></div><div id="wpp-2" class="et_pb_widget popular-posts"><h4 class="widgettitle">Popular Poats</h4><ul class="wpp-list"><li> <a href="https://seatacblog.com/2020/03/14/starting-monday-all-city-of-seatac-facilities-will-be-closed-due-to-coronavirus-outbreak/" class="wpp-post-title" target="_self">Starting Monday, all City of SeaTac facilities will be closed due to coronavirus outbreak</a> <span class="wpp-meta post-stats"><span class="wpp-views">20.2k views</span></span></li><li> <a href="https://seatacblog.com/2020/03/13/city-of-seatac-issues-proclamation-of-emergency-due-to-covid-19/" class="wpp-post-title" target="_self">City of SeaTac issues &#8216;Proclamation of Emergency&#8217; due to COVID-19</a> <span class="wpp-meta post-stats"><span class="wpp-views">9.9k views</span></span></li><li> <a href="https://seatacblog.com/2020/03/06/city-of-seatac-releases-statement-on-covid-19-coronavirus/" class="wpp-post-title" target="_self">City of SeaTac releases statement on COVID-19 Coronavirus</a> <span class="wpp-meta post-stats"><span class="wpp-views">6.4k views</span></span></li><li> <a href="https://seatacblog.com/2020/01/25/photos-videos-huge-walkway-installed-at-sea-tac-airports-international-arrivals-facility/" class="wpp-post-title" target="_self">PHOTOS/VIDEOS: Huge walkway installed at Sea-Tac Airport&#8217;s International Arrivals Facility</a> <span class="wpp-meta post-stats"><span class="wpp-views">5.3k views</span></span></li><li> <a href="https://seatacblog.com/2019/11/05/election-results-1-anderson-kwon-tombs-and-sitterley-have-early-leads/" class="wpp-post-title" target="_self">ELECTION RESULTS 1: Anderson, Kwon, Tombs and Sitterley have early leads</a> <span class="wpp-meta post-stats"><span class="wpp-views">3.5k views</span></span></li><li> <a href="https://seatacblog.com/2019/09/19/two-killed-in-horrific-collision-in-seatac-wednesday-night/" class="wpp-post-title" target="_self">Two killed in horrific collision in SeaTac Wednesday night</a> <span class="wpp-meta post-stats"><span class="wpp-views">3.1k views</span></span></li><li> <a href="https://seatacblog.com/2020/04/12/update-4-11-20-now-at-3-deaths-58-positive-in-seatac-due-to-covid-19/" class="wpp-post-title" target="_self">UPDATE 4/11/20: Now at 3 deaths, 58 positive in SeaTac due to COVID-19</a> <span class="wpp-meta post-stats"><span class="wpp-views">3k views</span></span></li><li> <a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/" class="wpp-post-title" target="_self">King County will turn Quality Inn hotel in SeaTac into temp shelter for homeless</a> <span class="wpp-meta post-stats"><span class="wpp-views">2.9k views</span></span></li><li> <a href="https://seatacblog.com/2020/03/14/seatac-police-help-make-big-undercover-drug-bust/" class="wpp-post-title" target="_self">SeaTac Police help make big undercover drug bust</a> <span class="wpp-meta post-stats"><span class="wpp-views">2.7k views</span></span></li><li> <a href="https://seatacblog.com/2020/05/28/police-seeking-publics-help-identifying-seatac-gas-station-robbery-suspect/" class="wpp-post-title" target="_self">Police seeking public&#8217;s help identifying SeaTac gas station robbery suspect</a> <span class="wpp-meta post-stats"><span class="wpp-views">2.5k views</span></span></li></ul></div><div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://www.kiro7.com/news/seattle-police-bust-couple-stolen-truck-property/246139424/' rel='external nofollow ugc' class='url'>seatac</a></span> on <a href="https://seatacblog.com/2020/10/05/seatac-police-seeking-publics-help-identifying-car-prowlers/#comment-18725">SeaTac Police seeking public&#8217;s help identifying car prowlers</a></li><li class="recentcomments"><span class="comment-author-link">Dave Upthegrove</span> on <a href="https://seatacblog.com/2020/12/03/katherine-kertzman-retiring-as-president-ceo-of-seattle-southside-regional-tourism-authority/#comment-17432">Katherine Kertzman retiring as President/CEO of Seattle Southside Regional Tourism Authority</a></li><li class="recentcomments"><span class="comment-author-link">Vicki Lockwood</span> on <a href="https://seatacblog.com/2020/07/16/sheriff-mitzi-g-johanknecht-concerned-about-lack-of-transparency-from-county-council/#comment-16354">Sheriff Mitzi G. Johanknecht &#8216;concerned about lack of transparency from County Council&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Nathanael Mills</span> on <a href="https://seatacblog.com/2020/07/16/sheriff-mitzi-g-johanknecht-concerned-about-lack-of-transparency-from-county-council/#comment-15407">Sheriff Mitzi G. Johanknecht &#8216;concerned about lack of transparency from County Council&#8217;</a></li><li class="recentcomments"><span class="comment-author-link">Carol Liedke</span> on <a href="https://seatacblog.com/2020/10/05/seatac-police-seeking-publics-help-identifying-car-prowlers/#comment-14827">SeaTac Police seeking public&#8217;s help identifying car prowlers</a></li></ul></div><div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76518" keywords="not_home_page,not_landing_page,is_article_page,burien,crime,featured-post,news,police,seatac,seatacnews,driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div></div></div></div></div><footer id="footer" class="footer_columns_3"><div id="footer-bottom"><div class="container"><p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p><div id="footer-nav"><ul class="et-extra-social-icons" style=""><li class="et-extra-social-icon facebook"> <a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a></li><li class="et-extra-social-icon twitter"> <a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a></li><li class="et-extra-social-icon instagram"> <a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a></li></ul></div></div></div></footer></div><div id="aioseo-admin"></div><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','burien','crime','featured-post','news','police','seatac','seatacnews','driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv','post']</script> <script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["burien","crime","featured-post","news","police","seatac","seatacnews","driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv","post"],"url":"driver-arrested-after-long-police-chase-through-seatac-wednesday-2-kids-were-inside-suv"};</script> <script data-cfasync='false'>window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script type="text/javascript"></script> <script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://seatacblog.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.8.1'></script> <script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );</script> <script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/dom-ready.min.js?ver=5316a69cb8a665ca6252926589751f9a' id='wp-dom-ready-js'></script> <script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/i18n.min.js?ver=326fe7fbfdb407b6edbcfba7e17f3909' id='wp-i18n-js'></script> <script type='text/javascript' id='wp-a11y-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/a11y.min.js?ver=693bc76804871970d5d4bf16475f9010' id='wp-a11y-js'></script> <script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};</script> <script type='text/javascript' id='extra-scripts-js-extra'>var EXTRA = {"images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"268c8f649d","timeline_nonce":"e21f76252d","blog_feed_nonce":"6c83def5b6","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};</script> <script type='text/javascript' id='et-builder-modules-script-js-extra'>var et_pb_custom = {"ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"4cbcfb6cdc","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"0d286eaac6","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"139526","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];</script> <script defer src="https://seatacblog.com/wp-content/cache/autoptimize/js/autoptimize_2d2d3d4311cc20de3c3b4437260d3513.js"></script></body></html>