<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" dir="ltr" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html dir="ltr" lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://seatacblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://seatacblog.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<title>After 46 years, Burien’s King Wha Restaurant will be closing Oct. 4 | The SeaTac Blog</title>
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin />

<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" />
<meta name="generator" content="All in One SEO (AIOSEO) 4.2.4 " />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The SeaTac Blog | SeaTac News, Crime, COVID-19, Events, Politics &amp; more" />
<meta property="og:type" content="article" />
<meta property="og:title" content="After 46 years, Burien’s King Wha Restaurant will be closing Oct. 4 | The SeaTac Blog" />
<meta property="og:url" content="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" />
<meta property="article:published_time" content="2022-09-08T21:06:06+00:00" />
<meta property="article:modified_time" content="2022-09-08T22:52:54+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/seatacblog" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@theseatacblog" />
<meta name="twitter:title" content="After 46 years, Burien’s King Wha Restaurant will be closing Oct. 4 | The SeaTac Blog" />
<meta name="twitter:creator" content="@theseatacblog" />

<script type="text/javascript">
			let jqueryParams=[],jQuery=function(r){return jqueryParams=[...jqueryParams,r],jQuery},$=function(r){return jqueryParams=[...jqueryParams,r],$};window.jQuery=jQuery,window.$=jQuery;let customHeadScripts=!1;jQuery.fn=jQuery.prototype={},$.fn=jQuery.prototype={},jQuery.noConflict=function(r){if(window.jQuery)return jQuery=window.jQuery,$=window.jQuery,customHeadScripts=!0,jQuery.noConflict},jQuery.ready=function(r){jqueryParams=[...jqueryParams,r]},$.ready=function(r){jqueryParams=[...jqueryParams,r]},jQuery.load=function(r){jqueryParams=[...jqueryParams,r]},$.load=function(r){jqueryParams=[...jqueryParams,r]},jQuery.fn.ready=function(r){jqueryParams=[...jqueryParams,r]},$.fn.ready=function(r){jqueryParams=[...jqueryParams,r]};</script><link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Feed" href="https://seatacblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Comments Feed" href="https://seatacblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The SeaTac Blog &raquo; iCal Feed" href="https://seatacblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4 Comments Feed" href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/feed/" />
<meta content="Extra v.4.18.0" name="generator" /><link rel='stylesheet' id='gtranslate-style-css' href='https://seatacblog.com/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://seatacblog.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://seatacblog.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://seatacblog.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://seatacblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=6.0.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<style id='extra-style-inline-inline-css' type='text/css'>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</style>
<style id='extra-dynamic-critical-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='social-logos-css' href='https://seatacblog.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://seatacblog.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.3' type='text/css' media='all' />
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jquery-js-after'>
jqueryParams.length&&$.each(jqueryParams,function(e,r){if("function"==typeof r){var n=String(r);n.replace("$","jQuery");var a=new Function("return "+n)();$(document).ready(a)}});
</script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=6.0.2' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<link rel="https://api.w.org/" href="https://seatacblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seatacblog.com/wp-json/wp/v2/posts/141844" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seatacblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seatacblog.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://seatacblog.com/?p=141844' />
<link rel="alternate" type="application/json+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F09%2F08%2Fb-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F09%2F08%2Fb-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4%2F&#038;format=xml" />
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','burien','business','featured-post','news','seatac','seatacnews','b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["burien","business","featured-post","news","seatac","seatacnews","b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4","post"],"url":"b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <meta property="fb:pages" content="293605064226" />
<style type="text/css">
.feedzy-rss-link-icon:after {
	content: url("https://seatacblog.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png");
	margin-left: 3px;
}
</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://seatacblog.com"><link rel="alternate" href="https://seatacblog.com/wp-json/tribe/events/v1/" /><style>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://seatacblog.com/wp-content/uploads/2020/09/STBFavicon.jpg" /><link rel="amphtml" href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/?amp">
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHDHPPP');</script>

<script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE SEATAC BLOG...').css('opacity','1'); 
});
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20430280-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20430280-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=VM5WbNEfwY9oXPbxN3ihiy5E";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://seatacblog.com/wp-content/et-cache/global/et-extra-customizer-global.min.css?ver=1662143364" /></head>
<body class="post-template-default single single-post postid-141844 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fixed_nav et_smooth_scroll et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.498039215686" /><feFuncG type="table" tableValues="0 0.498039215686" /><feFuncB type="table" tableValues="0 0.498039215686" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.549019607843 0.988235294118" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.717647058824 0.254901960784" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.278431372549" /><feFuncB type="table" tableValues="0.592156862745 0.278431372549" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.647058823529" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.780392156863 1" /><feFuncG type="table" tableValues="0 0.949019607843" /><feFuncB type="table" tableValues="0.352941176471 0.470588235294" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.650980392157 0.403921568627" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.447058823529 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.0980392156863 1" /><feFuncG type="table" tableValues="0 0.662745098039" /><feFuncB type="table" tableValues="0.847058823529 0.419607843137" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg> <div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-138191" class="et-trending-post et-trending-latest">
<a href="https://seatacblog.com/2019/10/31/letter-a-statement-from-seatac-city-council-candidate-takele-gobena/">LETTER: A statement from SeaTac City Council candidate ...</a>
</div>
<div id="et-trending-post-138718" class="et-trending-post">
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/">King County will turn Quality Inn hotel in SeaTac into ...</a>
</div>
<div id="et-trending-post-139049" class="et-trending-post">
<a href="https://seatacblog.com/2020/07/06/king-county-sheriff-issues-statement-regarding-offensive-facebook-posts/">King County Sheriff issues statement regarding offensiv...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://seatacblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://seatacblog.com/" data-fixed-height="51">
<img src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" width="360" height="260" alt="The SeaTac Blog" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-136055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-136055"><a href="https://seatacblog.com">Home</a></li>
<li id="menu-item-136190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136190"><a href="https://seatacblog.com/category/crime/">Crime</a></li>
<li id="menu-item-140620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140620"><a href="https://seatacblog.com/category/politics/">Politics</a></li>
<li id="menu-item-136174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136174"><a href="https://seatacblog.com/events/">Events</a></li>
<li id="menu-item-136059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136059"><a href="https://seatacblog.com/jobs/">Jobs</a></li>
<li id="menu-item-137992" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-137992"><a href="https://seatacblog.com/category/business/">Business</a></li>
<li id="menu-item-137987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137987"><a href="https://seatacblog.com/weather/">Weather</a></li>
<li id="menu-item-140120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140120"><a href="https://seatacblog.com/webcams/">Webcams</a></li>
<li id="menu-item-137986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137986"><a href="https://seatacblog.com/advertise/">Advertise</a></li>
<li id="menu-item-136062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136062"><a href="https://seatacblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136264"><a href="https://seatacblog.com/about/">About</a></li>
<li id="menu-item-139251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139251"><a href="https://seatacblog.com/support-local-journalism/">Support Local Journalism</a></li>
<li id="menu-item-139056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139056"><a href="https://seatacblog.com/subscribe-to-our-daily-digest-email-newsletter/">Subscribe to our Daily Digest Email Newsletter</a></li>
<li id="menu-item-136061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136061"><a href="https://seatacblog.com/contact/">Contact</a></li>
<li id="menu-item-136060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136060"><a href="https://seatacblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-138478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-138478"><a href="https://seatacblog.com/privacy-policy-terms/">Privacy Policy/Terms</a></li>
</ul>
</li>
<li id="menu-item-140208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-140208"><a href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2022/02/BHHSMenuButton200-22d.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="170" height="81"></a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-141844" class="module single-post-module post-141844 post type-post status-publish format-standard has-post-thumbnail hentry category-burien category-business category-featured-post category-news category-seatac category-seatacnews tag-burien tag-business tag-closing tag-king-wha-restaurant tag-news tag-restaurant tag-seatac et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4</h1>
<div class="post-meta vcard">
<p><span class="updated">Sep 8, 2022</span> | <a href="https://seatacblog.com/category/burien/" rel="tag">Burien</a>, <a href="https://seatacblog.com/category/business/" rel="tag">Business</a>, <a href="https://seatacblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://seatacblog.com/category/news/" rel="tag">News</a>, <a href="https://seatacblog.com/category/seatac/" rel="tag">SeaTac</a>, <a href="https://seatacblog.com/category/seatacnews/" rel="tag">SeaTac News</a> | <a class="comments-link" href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://seatacblog.com/wp-content/uploads/2022/09/BTB-KingWhaRestaurantYuFamily22-1280x640.jpg" alt="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<blockquote><p><em><strong>From our sister site <a href="https://b-townblog.com/2022/09/07/b-town-biz-after-46-years-burien-restaurant-king-wha-will-be-closing-oct-3/" target="_blank" rel="noopener">The B-Town Blog</a>:</strong></em></p></blockquote>
<p><strong>Sadly, after serving Burien residents great Chinese food for 46 years, King Wha Restaurant announced on Wednesday, Sept. 7, 2022 that they will be closing their business on Tuesday, Oct. 4, 2022.</strong></p>
<p>This popular restaurant operated by the Yu family and located at 605 SW 152nd Street has been serving the Burien community since 1976. </p>
<p>&#8220;You’ve celebrated birthdays, graduations, weddings, and more with us,&#8221; owners said in a <a href="https://www.facebook.com/KingWhaBurien/posts/pfbid02sNvg2km3QvGBHeRLZNLUaBBJuQGpqMrk5iGm2KxkUiicGLKDfGw7kpTUvqSRcqw7l" target="_blank" rel="noopener"><strong>Facebook post</strong></a>. &#8220;It has been our pleasure to serve you, your children, and your children’s children for almost half a century.&#8221; </p>
<p>&#8220;King Wha Restaurant has been a mainstay in Burien for so many years, but all good things must come to an end,&#8221; they added.</p>
<p>&#8220;Our guests have shown us so much love and support throughout the years, and we will be forever grateful. We hope you will come see us one more time in the coming weeks to have one last meal, and to say goodbye to the Yu family.&#8221;</p>
<p><strong>VIDEO INTERVIEW WITH OWNER</strong><br />
In 2011, South King Media Publisher Scott Schaefer Produced and Directed a documentary film called &#8220;<em>I Am Highline</em>&#8221; that included an interview with King Wha owner/operator Lien Yu, who reveals some of his personal and business history, with a comical answer to why customers return – fast forward to 43:36 to see his segment:</p>
<p><center><iframe loading="lazy" src="https://player.vimeo.com/video/27065374?h=8d25f19907&#038;byline=0&#038;portrait=0" width="640" height="284" frameborder="0" allow="autoplay; fullscreen; picture-in-picture" allowfullscreen></iframe></p>
<p><a href="https://vimeo.com/27065374">I Am Highline</a> from <a href="https://vimeo.com/kc4culture">4Culture</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
<p>This film project, produced by the Highline Historical Society, celebrates the ethnic composition of Highline through fascinating interviews of local residents. People representing 30 cultures that have moved to the Highline area talk about what it is like to live, work &amp; raise their families there. The video features candid conversations with residents in English and their native languages.</p>
<p></center></p>
<p>King Wha Restaurant is located at 605 SW 152nd Street:</p>
<p><center><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2789.296578028445!2d-122.34452278446027!3d47.46669430562556!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x5490449c9b0f6c0f%3A0xb5f7caa56442d47a!2sKing%20Wha%20Restaurant!5e1!3m2!1sen!2sus!4v1662589552308!5m2!1sen!2sus" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy" referrerpolicy="no-referrer-when-downgrade"></iframe></center></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" data-text="After 46 years, Burien&#039;s King Wha Restaurant will be closing Oct. 4">Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" data-layout="button_count"></div></li><li class="share-end"></li></ul></div></div></div><div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1765004079'><broadstreet-zone callback="zone_load_1765004079" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_1765004079 = function(z, d) { if (!d.count) document.getElementById('zone_load_1765004079').style.display = 'none'; };</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/&#038;t=After%2046%20years%2C%20Burien%E2%80%99s%20King%20Wha%20Restaurant%20will%20be%20closing%20Oct.%204" class="social-share-link" title="Share &quot;After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4&quot; via Facebook" data-network-name="facebook" data-share-title="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" data-share-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=After%2046%20years%2C%20Burien%E2%80%99s%20King%20Wha%20Restaurant%20will%20be%20closing%20Oct.%204%20https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" class="social-share-link" title="Share &quot;After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4&quot; via Twitter" data-network-name="twitter" data-share-title="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" data-share-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/&#038;title=After%2046%20years%2C%20Burien%E2%80%99s%20King%20Wha%20Restaurant%20will%20be%20closing%20Oct.%204" class="social-share-link" title="Share &quot;After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4&quot; via LinkedIn" data-network-name="linkedin" data-share-title="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" data-share-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4&quot; via Email" data-network-name="basic_email" data-share-title="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" data-share-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4&quot; via Print" data-network-name="basic_print" data-share-title="After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4" data-share-url="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #7ac8cc;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://seatacblog.com/2022/09/07/suspected-burglar-shot-and-killed-in-seatac-wednesday-morning/" rel="prev"><span class="button">Previous</span><span class="title">Suspected burglar shot and killed in SeaTac Wednesday morning</span></a> </div>
<div class="nav-link nav-link-next">
<a href="https://seatacblog.com/2022/09/08/noches-de-leyendas-mexicanas-will-be-saturday-sept-17-at-highline-heritage-museum/" rel="next"><span class="button">Next</span><span class="title">Noches de leyendas Mexicanas will be Saturday, Sept. 17 at Highline Heritage Museum</span></a> </div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://seatacblog.com/wp-comments-post.php?wpe-comment-post=seatacblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='141844' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="39589be294" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="0" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://seatacblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76520" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div class="tribe-compatibility-container">
<div class="tribe-common tribe-events tribe-events-view tribe-events-view--widget-events-list tribe-events-widget" data-js="tribe-events-view" data-view-rest-nonce="1dafb4e4a8" data-view-rest-url="https://seatacblog.com/wp-json/tribe/views/v2/html" data-view-manage-url="1" data-view-breakpoint-pointer="11eb497a-8440-4f70-a4e6-b14ce31359ea">
<div class="tribe-events-widget-events-list">
<script type="application/ld+json">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</script>
<script data-js="tribe-events-view-data" type="application/json">
	{"slug":"widget-events-list","prev_url":"","next_url":"","view_class":"Tribe\\Events\\Views\\V2\\Views\\Widgets\\Widget_List_View","view_slug":"widget-events-list","view_label":"Widget-events-list","view":null,"should_manage_url":true,"id":null,"alias-slugs":null,"title":"After 46 years, Burien\u2019s King Wha Restaurant will be closing Oct. 4 | The SeaTac Blog","limit":"7","no_upcoming_events":true,"featured_events_only":false,"jsonld_enable":true,"tribe_is_list_widget":false,"admin_fields":{"title":{"label":"Title:","type":"text","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-title","name":"widget-tribe-widget-events-list[2][title]","options":[],"placeholder":"","value":null},"limit":{"label":"Show:","type":"number","default":5,"min":1,"max":10,"step":1,"classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-limit","name":"widget-tribe-widget-events-list[2][limit]","options":[],"placeholder":"","value":null},"no_upcoming_events":{"label":"Hide this widget if there are no upcoming events.","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-no_upcoming_events","name":"widget-tribe-widget-events-list[2][no_upcoming_events]","options":[],"placeholder":"","value":null},"featured_events_only":{"label":"Limit to featured events only","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-featured_events_only","name":"widget-tribe-widget-events-list[2][featured_events_only]","options":[],"placeholder":"","value":null},"jsonld_enable":{"label":"Generate JSON-LD data","type":"checkbox","classes":"","dependency":"","id":"widget-tribe-widget-events-list-2-jsonld_enable","name":"widget-tribe-widget-events-list[2][jsonld_enable]","options":[],"placeholder":"","value":null}},"events":[141809,141796,141810,141825,141811],"url":"https:\/\/seatacblog.com\/?post_type=tribe_events&eventDisplay=widget-events-list","url_event_date":false,"bar":{"keyword":"","date":""},"today":"2022-09-08 00:00:00","now":"2022-09-08 15:53:04","rest_url":"https:\/\/seatacblog.com\/wp-json\/tribe\/views\/v2\/html","rest_method":"POST","rest_nonce":"1dafb4e4a8","today_url":"https:\/\/seatacblog.com\/?post_type=tribe_events&eventDisplay=widget-events-list&year=2022&monthnum=09&day=08&name=b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4","prev_label":"","next_label":"","date_formats":{"compact":"n\/j\/Y","month_and_year_compact":"n\/Y","month_and_year":"F Y","time_range_separator":" - ","date_time_separator":" @ "},"messages":[],"start_of_week":"0","breadcrumbs":[],"before_events":"","after_events":"\n<!--\nThis calendar is powered by The Events Calendar.\nhttp:\/\/evnt.is\/18wn\n-->\n","display_events_bar":false,"disable_event_search":false,"live_refresh":true,"ical":{"display_link":true,"link":{"url":"https:\/\/seatacblog.com\/?post_type=tribe_events&#038;eventDisplay=widget-events-list&#038;ical=1","text":"Export Events","title":"Use this to share calendar data with Google Calendar, Apple iCal and other compatible apps"}},"container_classes":["tribe-common","tribe-events","tribe-events-view","tribe-events-view--widget-events-list","tribe-events-widget"],"container_data":[],"is_past":false,"breakpoints":{"xsmall":500,"medium":768,"full":960},"breakpoint_pointer":"11eb497a-8440-4f70-a4e6-b14ce31359ea","is_initial_load":true,"public_views":{"month":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Month_View","view_url":"https:\/\/seatacblog.com\/events\/month\/","view_label":"Month"},"day":{"view_class":"Tribe\\Events\\Views\\V2\\Views\\Day_View","view_url":"https:\/\/seatacblog.com\/events\/today\/","view_label":"Day"}},"show_latest_past":false,"compatibility_classes":["tribe-compatibility-container"],"view_more_text":"View Calendar","view_more_title":"View more events.","view_more_link":"https:\/\/seatacblog.com\/events\/","widget_title":"Upcoming Events","hide_if_no_upcoming_events":true,"display":[],"subscribe_links":{"gcal":{"block_slug":"hasGoogleCalendar","label":"Google Calendar","single_label":"Add to Google Calendar","visible":true},"ical":{"block_slug":"hasiCal","label":"iCalendar","single_label":"Add to iCalendar","visible":true},"outlook-365":{"block_slug":"hasOutlook365","label":"Outlook 365","single_label":"Outlook 365","visible":true},"outlook-live":{"block_slug":"hasOutlookLive","label":"Outlook Live","single_label":"Outlook Live","visible":true}},"_context":{"slug":"widget-events-list"}}</script>
<header class="tribe-events-widget-events-list__header">
<h2 class="tribe-events-widget-events-list__header-title tribe-common-h6 tribe-common-h--alt">
Upcoming Events </h2>
</header>
<div class="tribe-events-widget-events-list__events">
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-09-08">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Sep </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
8 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141809 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-09-08">
<span class="tribe-event-date-start">6:30 pm</span> - <span class="tribe-event-time">8:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/skunk-works-robotics-open-house-2/" title="Skunk Works Robotics Open House" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Skunk Works Robotics Open House	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-09-10">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Sep </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
10 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141796 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-09-10">
<span class="tribe-event-date-start">10:00 am</span> - <span class="tribe-event-time">1:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/touch-a-truck-event-is-returning-to-seatac-on-saturday-sept-10/" title="Touch-A-Truck event is returning to SeaTac on Saturday, Sept. 10" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Touch-A-Truck event is returning to SeaTac on Saturday, Sept. 10	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-09-13">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Sep </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
13 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141810 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-09-13">
<span class="tribe-event-date-start">6:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/seatac-city-council-regular-meeting-3/" title="SeaTac City Council Regular Meeting" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
SeaTac City Council Regular Meeting	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-09-17">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Sep </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
17 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141825 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-09-17">
<span class="tribe-event-date-start">1:00 pm</span> - <span class="tribe-event-time">3:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/highline-seatac-botanical-gardens-ice-cream-social-will-be-saturday-sept-17/" title="Highline SeaTac Botanical Garden&#8217;s Ice Cream Social will be Saturday, Sept. 17" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
Highline SeaTac Botanical Garden&#8217;s Ice Cream Social will be Saturday, Sept. 17	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
<div class="tribe-common-g-row tribe-events-widget-events-list__event-row">
<div class="tribe-events-widget-events-list__event-date-tag tribe-common-g-col">
<time class="tribe-events-widget-events-list__event-date-tag-datetime" datetime="2022-09-27">
<span class="tribe-events-widget-events-list__event-date-tag-month">
Sep </span>
<span class="tribe-events-widget-events-list__event-date-tag-daynum tribe-common-h2 tribe-common-h4--min-medium">
27 </span>
</time>
</div>
<div class="tribe-events-widget-events-list__event-wrapper tribe-common-g-col">
<article class="tribe-events-widget-events-list__event post-141811 tribe_events type-tribe_events status-publish hentry">
<div class="tribe-events-widget-events-list__event-details">
<header class="tribe-events-widget-events-list__event-header">
<div class="tribe-events-widget-events-list__event-datetime-wrapper tribe-common-b2 tribe-common-b3--min-medium">
<time class="tribe-events-widget-events-list__event-datetime" datetime="2022-09-27">
<span class="tribe-event-date-start">6:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> </time>
</div>
<h3 class="tribe-events-widget-events-list__event-title tribe-common-h7">
<a href="https://seatacblog.com/event/seatac-city-council-regular-meeting-4/" title="SeaTac City Council Regular Meeting" rel="bookmark" class="tribe-events-widget-events-list__event-title-link tribe-common-anchor-thin">
SeaTac City Council Regular Meeting	</a>
</h3>
</header>
</div>
</article>
</div>
</div>
</div>
<div class="tribe-events-widget-events-list__view-more tribe-common-b1 tribe-common-b2--min-medium">
<a href="https://seatacblog.com/events/" class="tribe-events-widget-events-list__view-more-link tribe-common-anchor-thin" title="View more events.">
View Calendar	</a>
</div>
</div>
</div>
</div>
<script class="tribe-events-breakpoints">
	( function () {
		var completed = false;

		function initBreakpoints() {
			if ( completed ) {
				// This was fired already and completed no need to attach to the event listener.
				document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
				return;
			}

			if ( 'undefined' === typeof window.tribe ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views ) {
				return;
			}

			if ( 'undefined' === typeof window.tribe.events.views.breakpoints ) {
				return;
			}

			if ( 'function' !== typeof (window.tribe.events.views.breakpoints.setup) ) {
				return;
			}

			var container = document.querySelectorAll( '[data-view-breakpoint-pointer="11eb497a-8440-4f70-a4e6-b14ce31359ea"]' );
			if ( ! container ) {
				return;
			}

			window.tribe.events.views.breakpoints.setup( container );
			completed = true;
			// This was fired already and completed no need to attach to the event listener.
			document.removeEventListener( 'DOMContentLoaded', initBreakpoints );
		}

		// Try to init the breakpoints right away.
		initBreakpoints();
		document.addEventListener( 'DOMContentLoaded', initBreakpoints );
	})();
</script>
<div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://seatacblog.com/support-local-journalism/"><img width="300" height="250" src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="image wp-image-139276  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div> <div id="bs_zones-19" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78564" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://seatacblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe to our Daily Email Newsletter</h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our Daily Digest Email Newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> <div id="bs_zones-18" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#336666;border:1px solid #225555;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #225555'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Seattle-Tacoma International Airport</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-30'></i><span class='temp'>72°</span><div class='current_text'>Partly Cloudy</div><div class='sunrise_sunset'>6:37 am<i class='wi wi-fw wi-weather-32'></i>7:35 pm PDT</div></div><span class='current_text_2'>Feels like: 72<small>°F</small><br />Wind: 11<small>mph</small> NNE<br />Humidity: 35<small>%</small><br />Pressure: 30.2<small>"Hg</small><br />UV index: 4</span><div class='daily days' style='border-bottom:1px solid #225555'><span class='extended_day extended_day_1'>Fri</span><span class='extended_day extended_day_2'>Sat</span><span class='extended_day extended_day_3'>Sun</span><span class='extended_day extended_day_4'>Mon</span><span class='extended_day extended_day_5'>Tue</span></div><div class='daily'><span class='extended_day extended_day_1' title='Sunny'>81/59<small>°F</small><br /><i class='wi wi-fw wi-weather-32'></i></span><span class='extended_day extended_day_2' title='Sunny'>91/59<small>°F</small><br /><i class='wi wi-fw wi-weather-32'></i></span><span class='extended_day extended_day_3' title='AM Clouds / PM Sun'>82/57<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_4' title='Partly Cloudy'>75/55<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_5' title='Partly Cloudy'>73/54<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #225555'><a href='https://www.weather-us.com/en/washington-usa/seattle-tacoma-international-airport' title='Weather Atlas - Weather forecast Seattle-Tacoma International Airport, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Seattle-Tacoma International Airport, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone place="3" zone-id="89639" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76524" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://seatacblog.com/2022/09/08/noches-de-leyendas-mexicanas-will-be-saturday-sept-17-at-highline-heritage-museum/">Noches de leyendas Mexicanas will be Saturday, Sept. 17 at Highline Heritage Museum</a>
</li>
<li>
<a href="https://seatacblog.com/2022/09/08/b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4/" aria-current="page">After 46 years, Burien&#8217;s King Wha Restaurant will be closing Oct. 4</a>
</li>
<li>
<a href="https://seatacblog.com/2022/09/07/suspected-burglar-shot-and-killed-in-seatac-wednesday-morning/">Suspected burglar shot and killed in SeaTac Wednesday morning</a>
</li>
<li>
<a href="https://seatacblog.com/2022/09/05/firefighters-extinguish-blaze-at-homeless-encampment-sunday/">Firefighters extinguish blaze at homeless encampment Sunday</a>
</li>
<li>
<a href="https://seatacblog.com/2022/09/05/hydros-will-race-on-angle-lake-the-weekend-of-sept-9-11/">Hydros will race on Angle Lake the weekend of Sept. 9-11</a>
</li>
</ul>
</div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76512" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-25" class="et_pb_widget bs_zones"><div><broadstreet-zone place="" zone-id="76513" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://drdavedds.com' rel='external nofollow ugc' class='url'>Dave</a></span> on <a href="https://seatacblog.com/2022/06/07/wednesday-night-world-championships-at-north-seatac-park-welcomes-all-bike-riders/#comment-82635">Wednesday Night World Championships at North SeaTac Park welcomes all bike riders</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://remotoworkforce.com/' rel='external nofollow ugc' class='url'>Adrian</a></span> on <a href="https://seatacblog.com/2022/08/15/video-watch-highlights-from-the-maiden-voyage-of-the-des-moines-fast-ferry/#comment-82202">VIDEO: Watch highlights from the maiden voyage of the Des Moines Fast Ferry</a></li><li class="recentcomments"><span class="comment-author-link">margaret Almen</span> on <a href="https://seatacblog.com/2022/08/15/video-watch-highlights-from-the-maiden-voyage-of-the-des-moines-fast-ferry/#comment-82184">VIDEO: Watch highlights from the maiden voyage of the Des Moines Fast Ferry</a></li><li class="recentcomments"><span class="comment-author-link">Chuck d'Arielli</span> on <a href="https://seatacblog.com/2022/08/14/letter-irreplaceable-japanese-trees-stolen-from-seike-family-garden/#comment-81698">LETTER: Irreplaceable Japanese trees stolen from Seike Family Garden</a></li><li class="recentcomments"><span class="comment-author-link">Jones</span> on <a href="https://seatacblog.com/2022/06/07/wednesday-night-world-championships-at-north-seatac-park-welcomes-all-bike-riders/#comment-80004">Wednesday Night World Championships at North SeaTac Park welcomes all bike riders</a></li></ul></div> <div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76518" keywords="not_home_page,not_landing_page,is_article_page,burien,business,featured-post,news,seatac,seatacnews,b-town-biz-after-46-years-buriens-king-wha-restaurant-will-be-closing-oct-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<div style="position:fixed;bottom:0px;right:8%;z-index:999999;" id="gtranslate_wrapper">
<style>
.switcher {font-family:Arial;font-size:12pt;text-align:left;cursor:pointer;overflow:hidden;width:173px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:12pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#fff linear-gradient(180deg, #efefef 0%, #fff 70%);position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #ccc;color:#666;padding:3px 5px;width:161px;}
.switcher .selected a:after {height:24px;display:inline-block;position:absolute;right:10px;width:15px;background-position:50%;background-size:11px;background-image:url("data:image/svg+xml;utf8,<svg xmlns='http://www.w3.org/2000/svg' width='16' height='16' viewBox='0 0 285 285'><path d='M282 76.5l-14.2-14.3a9 9 0 0 0-13.1 0L142.5 174.4 30.3 62.2a9 9 0 0 0-13.2 0L3 76.5a9 9 0 0 0 0 13.1l133 133a9 9 0 0 0 13.1 0l133-133a9 9 0 0 0 0-13z' style='fill:%23666'/></svg>");background-repeat:no-repeat;content:""!important;transition:all .2s;}
.switcher .selected a.open:after {-webkit-transform: rotate(-180deg);transform:rotate(-180deg);}
.switcher .selected a:hover {background:#fff}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #ccc;border-right:1px solid #ccc;border-bottom:1px solid #ccc;background-color:#eee;display:none;width:171px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#fff;}
.switcher .option a.selected {background:#fff;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#f5f5f5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chinese (Simplified)" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/zh-CN.png" height="24" width="24" alt="zh-CN" /> Chinese (Simplified)</a><a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/en-us.png" height="24" width="24" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italian" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/it.png" height="24" width="24" alt="it" /> Italian</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/es-mx.png" height="24" width="24" alt="es" /> Spanish</a><a href="#" onclick="doGTranslate('en|uk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ukrainian" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/uk.png" height="24" width="24" alt="uk" /> Ukrainian</a><a href="#" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Vietnamese" class="nturl"><img data-gt-lazy-src="//seatacblog.com/wp-content/plugins/gtranslate/flags/24/vi.png" height="24" width="24" alt="vi" /> Vietnamese</a></div>
</div>
<script>
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style>#goog-gt-tt{display:none!important;}.goog-te-banner-frame{display:none!important;}.goog-te-menu-value:hover{text-decoration:none!important;}.goog-text-highlight{background-color:transparent!important;box-shadow:none!important;}body{top:0!important;}#google_translate_element2{display:none!important;}</style>
<div id="google_translate_element2"></div>
<script>function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}if(!window.gt_translate_script){window.gt_translate_script=document.createElement('script');gt_translate_script.src='https://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2';document.body.appendChild(gt_translate_script);}</script>
<script>
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(sel[i].className.indexOf('goog-te-combo')!=-1){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
<script>(function gt_jquery_ready() {if(!window.jQuery||!jQuery.fn.click) return setTimeout(gt_jquery_ready, 20);jQuery(document).ready(function() {var allowed_languages = ["zh-CN","en","it","es","uk","vi"];var accept_language = navigator.language.toLowerCase() || navigator.userLanguage.toLowerCase();switch(accept_language) {case 'zh-cn': var preferred_language = 'zh-CN'; break;case 'zh': var preferred_language = 'zh-CN'; break;case 'zh-tw': var preferred_language = 'zh-TW'; break;case 'zh-hk': var preferred_language = 'zh-TW'; break;case 'he': var preferred_language = 'iw'; break;default: var preferred_language = accept_language.substr(0, 2); break;}if(preferred_language != 'en' && GTranslateGetCurrentLang() == null && document.cookie.match('gt_auto_switch') == null && allowed_languages.indexOf(preferred_language) >= 0){doGTranslate('en|'+preferred_language);document.cookie = 'gt_auto_switch=1; expires=Thu, 05 Dec 2030 08:08:08 UTC; path=/;';var lang_html = jQuery('div.switcher div.option').find('img[alt="'+preferred_language+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));}});})();</script></div> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<div id="fb-root"></div>
<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<script>
			document.body.addEventListener( 'is.post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHDHPPP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<link rel='stylesheet' id='tec-variables-skeleton-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-skeleton.min.css?ver=5.0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=5.0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-skeleton-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-skeleton.min.css?ver=6.0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tec-variables-full-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/variables-full.min.css?ver=5.0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-full-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-full.min.css?ver=5.0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-widgets-v2-events-list-full-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/widget-events-list-full.min.css?ver=6.0.0.1' type='text/css' media='all' />
<script type='text/javascript' id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type='text/javascript' async src='https://clientcdn.pushengage.com/core/e960d6fd-bcdb-493b-b5a9-b537661ab0bf.js?ver=6.0.2' id='pushengage-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.13.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/dom-ready.min.js?ver=d996b53411d1533a84951212ab6ac4ff' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/hooks.min.js?ver=c6d64f2cb8f5c6bb49caca37f8828ce3' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/i18n.min.js?ver=ebee46757c6a411e38fd079a7ac71d94' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/dist/a11y.min.js?ver=a38319d7ba46c6e60f7f9d4c371222c5' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.13.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"6bf0ffff42","timeline_nonce":"8b8ef48b66","blog_feed_nonce":"225df5bb9c","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":true},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"};
var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_custom = {"ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"bfad29fcb0","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"acd07a46d9","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"141844","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra\/includes\/builder\/frontend-builder\/assets\/vendors","waypoints_options":[]};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.18.0' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/jquery.fitvids.js?ver=4.18.0' id='fitvids-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.18.0' id='et-core-common-js'></script>
<script defer type='text/javascript' src='https://seatacblog.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1658885495' id='akismet-frontend-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=5.0.0.1' id='tribe-common-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/utils/query-string.js?ver=5.0.0.1' id='tribe-query-string-js'></script>
<script src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script src='https://seatacblog.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script defer type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/manager.js?ver=6.0.0.1' id='tribe-events-views-v2-manager-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/js/views/breakpoints.js?ver=6.0.0.1' id='tribe-events-views-v2-breakpoints-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.3' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202236.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.3',blog:'186871394',post:'141844',tz:'-7',srv:'seatacblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '186871394', '141844' ]);
</script>
</body>
</html>
