<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://seatacblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://seatacblog.com';var et_post_id='140905';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Know someone who needs a ramp? ‘Rampathon’ now accepting applications | The SeaTac Blog</title>

<meta name="robots" content="max-image-preview:large" />
<link rel="canonical" href="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="The SeaTac Blog | SeaTac News, Crime, COVID-19, Events, Politics &amp; more" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Know someone who needs a ramp? ‘Rampathon’ now accepting applications | The SeaTac Blog" />
<meta property="og:url" content="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/" />
<meta property="article:published_time" content="2022-02-04T01:43:40+00:00" />
<meta property="article:modified_time" content="2022-02-04T01:44:26+00:00" />
<meta property="article:publisher" content="https://www.facebook.com/seatacblog" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@theseatacblog" />
<meta name="twitter:title" content="Know someone who needs a ramp? ‘Rampathon’ now accepting applications | The SeaTac Blog" />
<meta name="twitter:creator" content="@theseatacblog" />

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Feed" href="https://seatacblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Comments Feed" href="https://seatacblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The SeaTac Blog &raquo; iCal Feed" href="https://seatacblog.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="The SeaTac Blog &raquo; Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications Comments Feed" href="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/seatacblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<meta content="Extra v.2.27.4" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.9/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://c0.wp.com/c/5.9/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://c0.wp.com/c/5.9/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='wpb-google-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://seatacblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='https://seatacblog.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='extra-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://seatacblog.com/wp-content/themes/Extra-2/style.dev.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css' href='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/styles/magnific_popup.css?ver=2.27.4' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/5.9/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/10.6/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.6/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.9' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/seatacblog.com\/wp-json\/wordpress-popular-posts","ID":140905,"token":"5bcf529d20","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://seatacblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://seatacblog.com/wp-json/wp/v2/posts/140905" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://seatacblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://seatacblog.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://seatacblog.com/?p=140905' />
<link rel="alternate" type="application/json+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F02%2F03%2Fknow-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://seatacblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fseatacblog.com%2F2022%2F02%2F03%2Fknow-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps%2F&#038;format=xml" />
<meta property="fb:pages" content="293605064226" />
<meta property="ia:markup_url" content="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/?ia_markup=1" />
<style type="text/css">
		.feedzy-rss-link-icon:after {
			content: url( "https://seatacblog.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png" );
			margin-left: 3px;
		}
	</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://seatacblog.com"><link rel="alternate" href="https://seatacblog.com/wp-json/tribe/events/v1/" /> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://seatacblog.com/wp-content/uploads/2020/09/STBFavicon.jpg" /><link rel="amphtml" href="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/?amp">
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHDHPPP');</script>

<script>
jQuery(function($){
	$('#footer-info').html('&copy; '+(new Date).getFullYear()+' <a href="https://www.southkingmedia.com/about/">South King Media</a>');
});
</script>
<script>
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE SEATAC BLOG...').css('opacity','1'); 
});
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20430280-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20430280-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=VM5WbNEfwY9oXPbxN3ihiy5E";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://seatacblog.com/wp-content/cache/et/global/et-extra-customizer-global-164252816195.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-140905 single-format-standard tribe-no-js et_extra et_fullwidth_nav et_fixed_nav et_smooth_scroll et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="et-trending">

<div id="et-trending">

<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>

<h4 id="et-trending-label">
TRENDING: </h4>

<div id='et-trending-container'>
<div id="et-trending-post-138191" class="et-trending-post et-trending-latest">
<a href="https://seatacblog.com/2019/10/31/letter-a-statement-from-seatac-city-council-candidate-takele-gobena/">LETTER: A statement from SeaTac City Council candidate ...</a>
</div>
<div id="et-trending-post-138718" class="et-trending-post">
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/">King County will turn Quality Inn hotel in SeaTac into ...</a>
</div>
<div id="et-trending-post-139049" class="et-trending-post">
<a href="https://seatacblog.com/2020/07/06/king-county-sheriff-issues-statement-regarding-offensive-facebook-posts/">King County Sheriff issues statement regarding offensiv...</a>
</div>
</div>
</div>
</div>

<div id="et-info">

<ul class="et-extra-social-icons" style="">
 <li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://seatacblog.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="80">
<div class="container">


<a class="logo" href="https://seatacblog.com/" data-fixed-height="51">
<img src="https://seatacblog.com/wp-content/uploads/2020/04/STBLogoforExtra-4.png" alt="The SeaTac Blog" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-136055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-136055"><a href="https://seatacblog.com">Home</a></li>
<li id="menu-item-136190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136190"><a href="https://seatacblog.com/category/crime/">Crime</a></li>
<li id="menu-item-140620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140620"><a href="https://seatacblog.com/category/politics/">Politics</a></li>
<li id="menu-item-136174" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-136174"><a href="https://seatacblog.com/events/">Events</a></li>
<li id="menu-item-136059" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136059"><a href="https://seatacblog.com/jobs/">Jobs</a></li>
<li id="menu-item-137992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137992"><a href="https://seatacblog.com/category/business/">Business</a></li>
<li id="menu-item-137987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137987"><a href="https://seatacblog.com/weather/">Weather</a></li>
<li id="menu-item-140120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140120"><a href="https://seatacblog.com/webcams/">Webcams</a></li>
<li id="menu-item-138757" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-138757"><a href="https://seatacblog.com/category/COVID-19/">COVID-19</a></li>
<li id="menu-item-137986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137986"><a href="https://seatacblog.com/advertise/">Advertise</a></li>
<li id="menu-item-136062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136062"><a href="https://seatacblog.com/about/">About</a>
<ul class="sub-menu">
<li id="menu-item-136264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136264"><a href="https://seatacblog.com/about/">About</a></li>
<li id="menu-item-139251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139251"><a href="https://seatacblog.com/support-local-journalism/">Support Local Journalism</a></li>
<li id="menu-item-139056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139056"><a href="https://seatacblog.com/subscribe-to-our-daily-digest-email-newsletter/">Subscribe to our Daily Digest Email Newsletter</a></li>
<li id="menu-item-136061" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136061"><a href="https://seatacblog.com/contact/">Contact</a></li>
<li id="menu-item-136060" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136060"><a href="https://seatacblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-138478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-138478"><a href="https://seatacblog.com/privacy-policy-terms/">Privacy Policy/Terms</a></li>
</ul>
</li>
<li id="menu-item-140208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-140208"><a href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2019/10/BHHSLogoforMenu167x69.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="152" height="52"></a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-140905" class="module single-post-module post-140905 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-post category-health-and-wellness category-news category-seatac category-seatacnews tag-accessibility tag-free-ramps tag-master-builders-association tag-master-builders-association-of-king-and-snohomish-counties tag-mbaks tag-news tag-rampathon tag-seatac et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications</h1>
<div class="post-meta vcard">
<p><span class="updated">Feb 3, 2022</span> | <a href="https://seatacblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://seatacblog.com/category/health-and-wellness/" rel="tag">Health and Wellness</a>, <a href="https://seatacblog.com/category/news/" rel="tag">News</a>, <a href="https://seatacblog.com/category/seatac/" rel="tag">SeaTac</a>, <a href="https://seatacblog.com/category/seatacnews/" rel="tag">SeaTac News</a> | <a class="comments-link" href="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://seatacblog.com/wp-content/uploads/2022/02/SKM-RampathonApp2022-1280x640.jpg" alt="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><strong>The Master Builders Association of King and Snohomish Counties (MBAKS) – through its &#8216;Rampathon&#8217; program – is now accepting applications for free ramps for families struggling with mobility within their home or from non-profit organizations whose clients or residents struggle with mobility.</strong></p>
<p>Since 1993, MBAKS members and community volunteers have built more than 500 ramps to give people the freedom of movement throughout King and Snohomish County.</p>
<p>Applications are due March 4, 2022 – apply online here:</p>
<p style="text-align: center;"><strong><a href="https://app.smartsheet.com/b/form/14310eaa2bd841d0a775a81e149c3895" target="_blank" rel="noopener">https://app.smartsheet.com/b/form/14310eaa2bd841d0a775a81e149c3895</a></strong></p>

<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get more local SeaTac News FREE by email every day at 6pm!</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1899728112'><broadstreet-zone callback="zone_load_1899728112" zone-id="76232" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script>window.zone_load_1899728112 = function(z, d) { if (!d.count) document.getElementById('zone_load_1899728112').style.display = 'none'; };</script>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/&#038;t=Know%20someone%20who%20needs%20a%20ramp%3F%20%E2%80%98Rampathon%E2%80%99%20now%20accepting%20applications" class="social-share-link" title="Share &quot;Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications&quot; via Facebook" data-network-name="facebook" data-share-title="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" data-share-url="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Know%20someone%20who%20needs%20a%20ramp%3F%20%E2%80%98Rampathon%E2%80%99%20now%20accepting%20applications%20https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/" class="social-share-link" title="Share &quot;Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications&quot; via Twitter" data-network-name="twitter" data-share-title="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" data-share-url="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/&#038;title=Know%20someone%20who%20needs%20a%20ramp%3F%20%E2%80%98Rampathon%E2%80%99%20now%20accepting%20applications" class="social-share-link" title="Share &quot;Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" data-share-url="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications&quot; via Email" data-network-name="basic_email" data-share-title="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" data-share-url="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications&quot; via Print" data-network-name="basic_print" data-share-title="Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications" data-share-url="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #7464f2;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://seatacblog.com/2022/02/01/free-7-stories-storytelling-workshop-will-be-wed-feb-9-at-highline-heritage-museum/" rel="prev"><span class="button">Previous</span><span class="title">Free &#8216;7 Stories&#8217; Storytelling Workshop will be Wed., Feb. 9 at Highline Heritage Museum</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
 
<center><em>If you appreciate our independent local journalism, please…</em>
<div class="pp-donate-button"></div></center>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://seatacblog.com/wp-comments-post.php?wpe-comment-post=seatacblog" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='140905' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5fb5a1b098" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="62" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-2" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://seatacblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="76520" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-23" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="tribe-events-list-widget-3" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4> <p>There are no upcoming events at this time.</p>
</div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://seatacblog.com/support-local-journalism/"><img width="300" height="250" src="https://seatacblog.com/wp-content/uploads/2020/10/STBSupportAd300x250-1.jpg" class="image wp-image-139276  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" /></a></div> <div id="bs_zones-19" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="81629" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="78564" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-2" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://seatacblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Subscribe to our Daily Email Newsletter</h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=07d1ed2660" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our Daily Digest Email Newsletter</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_07d1ed2660" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> <div id="bs_zones-18" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76521" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76522" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="weather_atlas-2" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">Weather</h4><div class='weather-atlas-wrapper' style='background:#336666;border:1px solid #225555;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #225555'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Seattle-Tacoma International Airport</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-28'></i><span class='temp'>46°</span><div class='current_text'>Mostly Cloudy</div><div class='sunrise_sunset'>7:30am<i class='wi wi-fw wi-weather-32'></i>5:15pm PST</div></div><span class='current_text_2'>Feels like: 45<small>°F</small><br />Wind: 5<small>mph</small> S<br />Humidity: 79<small>%</small><br />Pressure: 30.41<small>"Hg</small><br />UV index: 0</span><div class='daily days' style='border-bottom:1px solid #225555'><span class='extended_day extended_day_1'>Fri</span><span class='extended_day extended_day_2'>Sat</span><span class='extended_day extended_day_3'>Sun</span><span class='extended_day extended_day_4'>Mon</span><span class='extended_day extended_day_5'>Tue</span></div><div class='daily'><span class='extended_day extended_day_1' title='Showers'>46/41<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_2' title='AM Clouds / PM Sun'>48/34<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_3' title='Mostly Cloudy'>50/37<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span><span class='extended_day extended_day_4' title='AM Showers'>50/37<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_5' title='Mostly Cloudy'>48/37<small>°F</small><br /><i class='wi wi-fw wi-weather-28'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #225555'><a href='https://www.weather-atlas.com/en/washington-usa/seattle-tacoma-international-airport' title='Weather Atlas - Weather forecast Seattle-Tacoma International Airport, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Seattle-Tacoma International Airport, Washington &#9656;</span></a></div></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone place="3" zone-id="89639" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-14" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76524" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76512" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://seatacblog.com/2022/02/03/know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps/" aria-current="page">Know someone who needs a ramp? &#8216;Rampathon&#8217; now accepting applications</a>
</li>
<li>
<a href="https://seatacblog.com/2022/02/01/free-7-stories-storytelling-workshop-will-be-wed-feb-9-at-highline-heritage-museum/">Free &#8216;7 Stories&#8217; Storytelling Workshop will be Wed., Feb. 9 at Highline Heritage Museum</a>
</li>
<li>
<a href="https://seatacblog.com/2022/02/01/rotary-club-of-seatac-tukwila-seeking-sponsors-for-its-scholarship-program/">Rotary Club of SeaTac-Tukwila seeking sponsors for its Scholarship Program</a>
</li>
<li>
<a href="https://seatacblog.com/2022/02/01/shots-fired-incidents-increased-by-54-percent-in-2021-prosecutors-office-says/">Shots fired incidents increased by 54 percent in 2021, Prosecutor&#8217;s Office says</a>
</li>
<li>
<a href="https://seatacblog.com/2022/02/01/seattle-southside-chamber-supporting-black-businesses-is-celebrating-black-history/">Seattle Southside Chamber: Supporting Black Businesses is Celebrating Black History</a>
</li>
</ul>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Poats</h4>
<ul class="wpp-list">
<li>
<a href="https://seatacblog.com/2020/03/14/starting-monday-all-city-of-seatac-facilities-will-be-closed-due-to-coronavirus-outbreak/" class="wpp-post-title" target="_self">Starting Monday, all City of SeaTac facilities will be closed due to coronavirus outbreak</a>
<span class="wpp-meta post-stats"><span class="wpp-views">20.8k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/13/city-of-seatac-issues-proclamation-of-emergency-due-to-covid-19/" class="wpp-post-title" target="_self">City of SeaTac issues &#8216;Proclamation of Emergency&#8217; due to COVID-19</a>
<span class="wpp-meta post-stats"><span class="wpp-views">10.5k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/03/06/city-of-seatac-releases-statement-on-covid-19-coronavirus/" class="wpp-post-title" target="_self">City of SeaTac releases statement on COVID-19 Coronavirus</a>
<span class="wpp-meta post-stats"><span class="wpp-views">6.9k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/01/25/photos-videos-huge-walkway-installed-at-sea-tac-airports-international-arrivals-facility/" class="wpp-post-title" target="_self">PHOTOS/VIDEOS: Huge walkway installed at Sea-Tac Airport&#8217;s International Arrivals Facility</a>
<span class="wpp-meta post-stats"><span class="wpp-views">6.4k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2020/04/02/king-county-will-turn-quality-inn-hotel-in-seatac-into-temp-shelter-for-homeless/" class="wpp-post-title" target="_self">King County will turn Quality Inn hotel in SeaTac into temp shelter for homeless</a>
<span class="wpp-meta post-stats"><span class="wpp-views">4.3k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/11/05/election-results-1-anderson-kwon-tombs-and-sitterley-have-early-leads/" class="wpp-post-title" target="_self">ELECTION RESULTS 1: Anderson, Kwon, Tombs and Sitterley have early leads</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.8k views</span></span>
</li>
<li>
<a href="https://seatacblog.com/2019/09/19/two-killed-in-horrific-collision-in-seatac-wednesday-night/" class="wpp-post-title" target="_self">Two killed in horrific collision in SeaTac Wednesday night</a>
<span class="wpp-meta post-stats"><span class="wpp-views">3.7k views</span></span>
</li>
</ul>
</div> 
<div id="recent-comments-2" class="et_pb_widget widget_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">jacque</span> on <a href="https://seatacblog.com/2022/01/25/king-county-prosecuting-attorneys-office-testifies-on-how-to-curb-demand-for-catalytic-converter-theft/#comment-63946">King County Prosecuting Attorney’s Office testifies on how to curb demand for catalytic converter theft</a></li><li class="recentcomments"><span class="comment-author-link">Vicki Lockwood</span> on <a href="https://seatacblog.com/2022/01/01/seattle-southside-chamber-resolutions/#comment-59603">Seattle Southside Chamber: Resolutions</a></li><li class="recentcomments"><span class="comment-author-link">Yug Dabadi</span> on <a href="https://seatacblog.com/2020/11/02/ticketed-travelers-can-get-tested-for-covid-19-at-sea-tac-airport-starting-nov-4/#comment-58933">Ticketed travelers can get tested for COVID-19 at Sea-Tac Airport starting Nov. 4</a></li><li class="recentcomments"><span class="comment-author-link">Mysty Beal</span> on <a href="https://seatacblog.com/2021/11/12/what-are-you-looking-for-in-highline-public-schools-next-superintendent/#comment-55096">What are you looking for in Highline Public Schools’ next superintendent?</a></li><li class="recentcomments"><span class="comment-author-link">Kevin</span> on <a href="https://seatacblog.com/2021/12/01/jake-simpson-sworn-in-as-newest-seatac-city-councilmember/#comment-54433">Jake Simpson sworn in as newest SeaTac City Councilmember</a></li></ul></div> <div id="bs_zones-8" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76518" keywords="not_home_page,not_landing_page,is_article_page,featured-post,health-and-wellness,news,seatac,seatacnews,know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_3">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>
 
<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com/seatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com/theseatacblog" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://www.instagram.com/seatacblog/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
</li>
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','featured-post','health-and-wellness','news','seatac','seatacnews','know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["featured-post","health-and-wellness","news","seatac","seatacnews","know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps","post"],"url":"know-someone-who-needs-a-ramp-rampathon-accepting-applications-for-free-ramps"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHDHPPP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<link rel='stylesheet' id='tribe-events-custom-jquery-styles-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=5.13.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=5.13.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css' href='https://seatacblog.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css?ver=5.13.0' type='text/css' media='all' />
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-global-functions.js?ver=2.27.4' id='et-builder-modules-global-functions-script-js'></script>
<script type='text/javascript' id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type='text/javascript' async src='https://clientcdn.pushengage.com/core/e960d6fd-bcdb-493b-b5a9-b537661ab0bf.js?ver=5.9' id='pushengage-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/ui/menu.min.js' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/ui/autocomplete.min.js' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/smoothscroll.js?ver=2.27.4' id='smooth-scroll-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/masonry.min.js' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images\/","ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"89adab9b09","timeline_nonce":"7530e01cb4","blog_feed_nonce":"8b62738ac7","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/scripts.js?ver=2.27.4' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/scripts/ext/jquery.raty.js?ver=2.27.4' id='raty-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.fitvids.js?ver=2.27.4' id='divi-fitvids-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/waypoints.min.js?ver=2.27.4' id='waypoints-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.magnific-popup.js?ver=2.27.4' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/jquery.mobile.custom.min.js?ver=2.27.4' id='et-jquery-touch-mobile-js'></script>
<script type='text/javascript' id='et-builder-modules-script-js-extra'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/seatacblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/images","builder_images_uri":"https:\/\/seatacblog.com\/wp-content\/themes\/Extra-2\/includes\/builder\/images","et_frontend_nonce":"342d3fbbfe","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"5c40a03842","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"140905","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/includes/builder/scripts/frontend-builder-scripts.js?ver=2.27.4' id='et-builder-modules-script-js'></script>
<script type='text/javascript' src='https://seatacblog.com/wp-content/themes/Extra-2/core/admin/js/common.js?ver=3.27.4' id='et-core-common-js'></script>
<script src='https://stats.wp.com/e-202205.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6',blog:'186871394',post:'140905',tz:'-8',srv:'seatacblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '186871394', '140905' ]);
</script>
</body>
</html>
